Ask Your Question

Image damaged when printing or exporting to PDF [closed]

asked 2015-10-27 10:39:40 +0200

D.Bugger gravatar image

updated 2015-10-28 03:12:32 +0200

Alex Kemp gravatar image

The title says it all. The image displays correctly on the screen, even in Print Preview, but when printed to PDF (through PDFCreator or Microsoft's PDF printer) or exported to PDF, either only the left part of it is shown or it is squashed into something garbled that's about 10 pixels high.

W10, LibreOffice, Java 8.65

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-15 17:21:41.720999


I can't reproduce the issue with Win10x64 and Ver: (x64) even with a low resolution exporting as pdf. Please verify that Menu/Options/LibreOffice/View-Graphics view options have not influence on it. If no luck, try resetting the user profile, sometimes solves strange issues, and it's more frequent having problems with it after update.

m.a.riosv gravatar imagem.a.riosv ( 2015-10-30 23:09:16 +0200 )edit

How to reset the user profile:

m.a.riosv gravatar imagem.a.riosv ( 2015-11-02 17:30:07 +0200 )edit

Progress. In the PDF options, when exporting to PDF, I selected Lossless compression and now Export to PDF behaves correctly. When I print through PDFCreator, the image disappears and seems replaced by always the same inkdrops at the top.

What I get is this, using PDFCreator:

MS Print to PDF does the same:

D.Bugger gravatar imageD.Bugger ( 2015-11-04 14:27:04 +0200 )edit
D.Bugger gravatar imageD.Bugger ( 2015-11-08 12:32:37 +0200 )edit

2 Answers

Sort by » oldest newest most voted

answered 2015-11-09 00:06:56 +0200

I think I figured this out.

It was to do with the OpenGL. Under Tools>Options>View>Graphics Output, uncheck "Use OpenGL for all rendering." Close LibreOffice completely and reopen and you should be able to print (it won't work if you don't close everything completely).

I had the same problem on my main system, but things were working fine on my other systems. The differences is the other two computers had AMD graphics cards and my main one had an Nvidia GeForce 560 GTX. Under Graphics Output the "Use hardware acceleration" option was faded. When I unchecked "Use OpenGL for all rendering," the "Use hardware acceleration" option was selectable again.

Hope this helps.

edit flag offensive delete link more


Thanks! Switching off OpenGL helped. Great advice.

roman gravatar imageroman ( 2015-11-09 22:06:25 +0200 )edit

It helped. :)


D.Bugger gravatar imageD.Bugger ( 2015-11-10 22:36:21 +0200 )edit

Kudos! This solved my problem as well.

cherio gravatar imagecherio ( 2016-02-29 18:02:22 +0200 )edit

THANK YOU SO MUCH!!!!!!!!!!!!!!!!!!!! We almost stopped using draw because our images would be all distorted.

jimmybsilva gravatar imagejimmybsilva ( 2017-02-14 20:18:09 +0200 )edit

More than two years since the previous comment this answer is still helping. Thanks

bph84 gravatar imagebph84 ( 2019-03-05 16:35:56 +0200 )edit

Thank You very much. I create many calcs tables with pictures and export them to PDF and from update last year some of them were stretched to the side (preview were OK). I tried to reinsert images converted to a different format (JPG sometimes help), but Your solutions works great :-)

Ondrej Ulman gravatar imageOndrej Ulman ( 2019-03-06 13:46:25 +0200 )edit

answered 2015-10-30 19:33:21 +0200

oparoz gravatar image

Same problem here. My headers are either missing or squashed/destoyed. I've tried re-adding the image, but it doesn't change anything.

I'm using 300DPI graphics

Still a problem on 5.0.3

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-10-27 10:39:40 +0200

Seen: 7,030 times

Last updated: Oct 30 '15