Ask Your Question
1

Docx files open with one line to a page [closed]

asked 2012-09-15 22:03:35 +0100

untmdsprt gravatar image

updated 2015-09-09 16:20:49 +0100

Alex Kemp gravatar image

Everytime I open a docx file, the paragraph marker is formatted as a page break instead of the normal function. How can I quickly fix this, and is there a permanent fix to this behavior?

I am using the Mac Intel version 3.6.0.4 (Build ID: 932b512).

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-20 18:45:24.166812

3 Answers

Sort by » oldest newest most voted
0

answered 2012-09-17 08:38:14 +0100

Bart_ gravatar image

My personal experience with LibreOffice + Docx on Mac is that it never really opens it correctly.

Paragraphs and page breaks are one issue that I've come across. Another is an issue with symbols which can be bypassed by using the replacement table, but this only helps LO since when you open the Docx under MS Word it will be wrongly formatted again. . .

Overall I tend to avoid Docx, as a result I save everything in odt and send PDF's around for those that need to read it.

Not a good answer but this is my experience on my Mac with Docx. No matter what you try, it simply won't be perfect in terms of formatting and moving documents from MS Word to LO and back. (every time you do this it will break something new)

edit flag offensive delete link more
0

answered 2012-09-19 14:23:36 +0100

untmdsprt gravatar image

Thanks for your comment. I've heard other people say the same thing, and so I'm sticking with the old "doc" format when I need to send a MS Word formatted document.

I might try your way of saving in oct and send as PDF to see that helps.

edit flag offensive delete link more
0

answered 2014-04-02 12:04:52 +0100

Sadie gravatar image

updated 2014-04-02 13:24:21 +0100

Very wierd solution, but this worked for me:

Open the docx in LibreOffice.

Select & copy all.

Open a new document in OpenOffice.

Paste.

Hit F11 to bring up the styles menu.

Top of the list is a style called Default.

Right click, Modify...

Click Text Flow.

Uncheck Breaks Insert Page.

Hit OK.

Et - voila! Now the file is fixed, and you can save it as a regular .doc

You are probably wondering why this solution needs both LibreOffice and OpenOffice.

The reason is that editing the page styles didn't seem to work in LibreOffice 4.2. OpenOffice 4.0 could fix the styles... but it couldn't even OPEN the original file!

I hope this be of use to bug-hunters in both teams.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-09-15 22:03:35 +0100

Seen: 1,961 times

Last updated: Apr 02 '14