Ask Your Question

Printing from Calc: Wrong Characters appear on page (square with ? inside) [closed]

asked 2015-11-30 14:52:24 +0100

PeterLairo gravatar image

updated 2020-08-31 21:00:44 +0100

Alex Kemp gravatar image

When printing a Calc document using LibreOffice in Windows 7, I get squares with questionmarks inside them instead of the letter "u". Not all "u"s are affected. Some print correctly. It seems to occur inside words that are bold. Exporting to PDF doesn't have this problem, and printing from older versions also didn't have this problem.

Printer: XEROX FreeFlow 4112 PS. Font used: Calibri

UPDATE (17.12.2015): I've narrowed it down a bit: When I change the header text from my preferred "Calibri" to the default "Liberation Sans", the problem goes away for all bold "u"s (body and header) (even when the body text remains "Calibri"). For some reason, LibreOffice 5.x doesn't like Calibri to be in the header. For some reason, I cannot reproduce this with a new Calc document...

Screenshot of printed page showing bug:

image description

Screenshot of printer driver settings:

image description

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-31 21:02:14.657101

2 Answers

Sort by » oldest newest most voted

answered 2016-03-12 12:09:13 +0100

Alex Kemp gravatar image

An OpenGL bug affecting display + printing was fixed only at the end of December 2015. See Q64314 for more info + fixes.

edit flag offensive delete link more

answered 2015-11-30 23:00:11 +0100

Lupp gravatar image

updated 2015-11-30 23:01:16 +0100

(What is your operating system?) 'Calibri' is a ttf font family licensed by Microsoft.

1) Are you sure you have your Calibri fonts in the right place on your system?

If yes:

1a) Is there (unintentionally) defined a replacement for the used font in LibreOffice?

If no:

1b) You do not know? Learn about the fonts on your system.

1c) It is not available? MAke it available or REplace it with a proper font for LibreOffice or USe another font for your text.

2) Further investigation needed. Do you want suggestions?

edit flag offensive delete link more


My OS is Windows 7 (as mentioned in my OP). There are no replacement fonts in Options / LO / Fonts. Windows fonts are "proper fonts" and are available to all programs. There is no need to "replace" them. This is clearly a LO bug, since (a) it worked before, and (b) it is a LO-only phenomenon. Yes, I would like further suggestions. TIA.

PeterLairo gravatar imagePeterLairo ( 2015-12-01 15:30:31 +0100 )edit

"This is clearly a LO bug," You are sure? I am not. Do you know someone else using the same printer with the same driver? Did you try another driver for the printer? Can you try another printer? Do you also use a 'Calibri Bold' font? ...

Bug reports are to file at .

Lupp gravatar imageLupp ( 2015-12-06 00:04:30 +0100 )edit

I just installed the latest OpenOffice (4.1.2) and printed the SAME file to the SAME printer from the SAME computer. And guess what: The bold "u"s printed correctly. Therefore, I'm reasonably sure this is a regression bug in LibreOffice 5.x.

PeterLairo gravatar imagePeterLairo ( 2015-12-17 13:52:35 +0100 )edit

Question Tools

1 follower


Asked: 2015-11-30 14:52:24 +0100

Seen: 516 times

Last updated: Mar 12 '16