Ask Your Question
0

Why is Libre Office Vanilla frequently crashing on my MacBook Pro running El Capitan?

asked 2015-12-07 18:46:09 +0100

Lindy4444 gravatar image

updated 2015-12-12 20:17:19 +0100

Alex Kemp gravatar image

We updated the MacBook to El Capitan and downloaded Libre Office Vanilla from the Mac Store, thinking it would be most likely to be happy with the Mac - before this we would run the latest update of Libre Office, downloaded from Libre Office. This says it is version 5.0.2.2 It crashed out during editing several times, fortunately my files were recovered, but I couldn't restart it without immediate crash, or whirling beachball of death and an eventual Force Quit. I have Microsoft Office which I use if I have to, so I have been, and it works fine. Tried Libre Office Vanilla again today, launching it from the launchpad thing, it crashed as soon as I select a file from the page of files I can open (actually I wanted to start a new document). It reliably crashes when "launched". It will start if I just open a file. But then crashes at some point during editing, I think when I am switching between software.

This is what it says when it crashes on opening: "Due to an unexpected error, LibreOffice crashed. All the files you were working on will now be saved. The next time LibreOffice is launched, your files will be recovered automatically."

I also use LibreOffice on a desktop running Fedora, and I can move documents to the other computer easily via Dropbox. So nothing is urgent, it is just disappointing.

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-12-12 07:35:35 +0100

jay Arr gravatar image

updated 2015-12-23 18:50:19 +0100

There are known problems and a Bugzilla report about this subject see LO 4.4 and 5.0.2 fail on El Capitan in this forum

23-Dec-15 Further to my previous comment of 12-Dec-15

I have been experimenting with various combinations of LO & Java on OSX 10.11 (El Capitan) attempting to run my split database application for which the same database file runs successfully on all other OSX versions, Windows 7, & 10 and Ubuntu 14.10 with various LO Still & Fresh versions & several recent JREs.

The good news: I can successfully get LO v5.1.0.1 and JRE 1.8.0_60 on OSX10.11 to run and create a simple 1 table + 1 form EMBEDDED database using BASE.

The not so good news (and this is where I think the problem lies): if I attempt to split the database (i.e. replicate the situation with my application) following the instructions at this [link in the open office forum] ( https://forum.openoffice.org/en/forum... )

I have found that when I attempt to open the template wizard file Split_HSQLDB_2.3.2_Wizard_v3d.odb as per instruction 5, LO locks up my system with the activity monitor showing that it''s using > 100% of one of my two systems CPUs. Indeed the only way I can regain control (Force Quit doesn't work) is to abort the LO process via the activity monitor.This characteristic of a system lock up or freeze is identical to what I see when I attempt to initiate my applications split database.

The conclusion I'm coming to is that the apparent problems with OSX 10.11, LO & Java are co-incident with initiating a split database. This excessive CPU usage under OSX 10.11 was reported (and fixed) in Bugzilla in back August when beta versions of the new OSX were made available.

I thought this worth reporting here.

I have submited a report on my findings to Bugzilla. If you want to track the progress it's bug number 96696

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-12-07 18:46:09 +0100

Seen: 678 times

Last updated: Dec 23 '15