Ask Your Question
0

How to remove read-only from a doc?

asked 2015-12-11 03:19:49 +0200

1470rpb gravatar image

I never want read-only but my docs keep coming up with it. Why and how do I specify write enabled on the whole document?

edit retag flag offensive close merge delete

Comments

I have the same problem. Can anyone help?

Buster Boy gravatar imageBuster Boy ( 2017-07-09 23:56:55 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2019-02-28 23:51:57 +0200

lserni gravatar image

I have just had the same problem on a Mac. The document remains locked even if saved as DOCX and moved to a Windows machine.

The culprit was this setting, weird as it looks.

Tools > Options > LibreOffice Writer > Compatibility > Protect Form

This behaviour is documented in the LibreOffice Wiki (which is where I found the tip).

edit flag offensive delete link more

Comments

That helped, but once. If I save the document, the next time when I open again, it shows only read mode. That strangely happens only to docx file format.

OSS-user gravatar imageOSS-user ( 2019-05-28 09:34:30 +0200 )edit
0

answered 2017-11-11 12:54:29 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

  1. Quick cheat, useful if you upen really read-only file (mail attachment or url for example) - Menu: Edit - Edit mode
  2. If you open local file. Check you have write permissions and read-only flag not set for file.
  3. Read-only mode by default can be set in document properties (File - Properties - Security)
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-12-11 03:19:49 +0200

Seen: 4,757 times

Last updated: Feb 28