Ask Your Question
0

Cannot install 5.0.4 .deb Linux package

asked 2015-12-20 03:10:48 +0200

paul1149 gravatar image

updated 2015-12-22 04:49:40 +0200

Alex Kemp gravatar image

I downloaded the x64 package for v 5.0.4, then I extracted it. I am left with a folder full of .deb packages. Trying the most likely package, which had no module name, failed with a dependencies error. So I went with the "core" package, which at 190mb is much larger. It too failed with that error.

How does one install this version? I'm on Linux Lite 2.6, a ubuntu 14.04 derivative.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2015-12-20 03:31:04 +0200

razon_22 gravatar image

After extracting the .deb file, there should be a readmes folder with a read me file alongside the deb folder with instructions on installing it. After reading it, open the deb folder, right-click and choose Open In Terminal. Enter this in the terminal and press enter:

sudo dpkg -i *.deb

You'll be asked for your password. Enter it and LibreOffice should install.

edit flag offensive delete link more

Comments

Thank you. I overlooked that, thinking this would be a one-click deal. After seeing the requirements for installation, I am going to forego this and wait for the official distribution, rather than search out whether my system is up to the new install. Thanks again.

paul1149 gravatar imagepaul1149 ( 2015-12-20 13:43:21 +0200 )edit

There are PPA repositories for LO that work with Ubuntu and, I think, Mint. I don't know if they are compatible with Linux Lite.

mikebibo gravatar imagemikebibo ( 2015-12-21 01:52:42 +0200 )edit

@mikebibo: any distro directly based on Ubuntu without changing the core system or using an alternative "unsupported" package means Ubuntu packages will run on it. What Ubuntu release, CPU type and if applicable the bit width is dictates what packages you can install, as you should be aware.

rautamiekka gravatar imagerautamiekka ( 2016-01-04 00:58:25 +0200 )edit
0

answered 2016-01-26 21:07:53 +0200

You did not say if this was a new installation or if you were trying to upgrade from a previously installed version of LO. Regardless, below is a link to my instructions to myself on how to install the package. If yours was a new installation, you might want to refer to these instructions when you get ready to update. Of course, you can do as you said and simply install the package available in your OS, but I find it very unsatisfying to wait for what seems like forever for updates to become available in the Software Package Installer. In my instructions, note that in addition to purging the existing (if any) version of LO, the only steps you need to complete are those highlighted in yellow and in green. Really, it is simply a couple of steps. Hope this helps. https://drive.google.com/open?id=0BxD...

edit flag offensive delete link more

Comments

Thanks. Does that "purge" switch delete all existing user settings and templates?

paul1149 gravatar imagepaul1149 ( 2016-01-27 16:29:11 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-12-20 03:10:48 +0200

Seen: 288 times

Last updated: Jan 26 '16