Ask Your Question

LibreOffice can not handle utf-8 file or directory names [closed]

asked 2015-12-23 00:19:14 +0200

Digital bear gravatar image

My question is similar to this one: , but more specific. I wasn't sure whether to ask a new question or post a comment.

The behaviour of LibreOffice in a UTF-8 environment seems to be broken. :( To wit:

When opening any file with any multibyte characters in the name LibreOffice tells me that the file does not exist. To be more specific:

  • Using the Open File dialogue box, all UTF-8 encoded file and directory names are garbled. For example, "Elŝutujo" appears as "Elŝutujo"
  • Using the Open File dialogue box, attempting to descend such a garbled directory or open such a file results in an error stating that the directory or directory does not exist
  • Attempting to open a file externally (using the operating system's file manager + file associations) results in the same "file or directory does not exist" error if the file has multi-byte characters in its name or is in a directory with multi-byte characters in its name.


  • LibreOffice
  • Kubuntu (Ubuntu 14.04.3 + KDE 4.13.3)
  • LANG=eo.UTF-8
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-11 15:43:03.921036

1 Answer

Sort by » oldest newest most voted

answered 2016-01-03 09:24:33 +0200

oweng gravatar image

As the answer in the linked thread indicates I am unable to reproduce this issue. I use Debian + LXDE + Openbox + en_AU.UTF-8 with all kinds of foreign characters in directories and filenames. These types of issues IMO are generally the result of an incorrect system setting.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-12-23 00:13:09 +0200

Seen: 1,249 times

Last updated: Jan 03 '16