Ask Your Question
0

Keyboard shortcut for "Insert Rows" (Calc) only works with numeric keypad?!?!?

asked 2016-01-03 21:08:15 +0200

stephenb gravatar image

According to several sources, the keyboard shortcut to insert a new row in LO Calc is "Ctrl-+" - but it won't work for most keyboards these days, because it only works if you have a dedicated + key, which are only present on full-size keyboard with numeric keypads. Otherwise, the + symbol requires pressing "Shift-=" - and while Ctrl-Shift-= does work in Excel, LO Calc fails to recognize as the keyboard shortcut.

Oh, and it looks like the options allow any key to be used for a keyboard shortcut... EXCEPT for the "=" key, making it impossible to fix the issue that way.

Is there another fix/workaround so that the =/+ key can be used for the "New Row" keyboard shortcut?

edit retag flag offensive close merge delete

Comments

Yes its odd in that Ctrl-Shift = works on MS Excel.

peterwt gravatar imagepeterwt ( 2016-01-06 11:53:26 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2016-01-06 11:29:46 +0200

pierre-yves samyn gravatar image

Hi

Sorry, I know of no way to use this shortcut...

However as a workaround, the Standard toolbar now includes Insert Rows (Columns) buttons that do not need to select the header to insert an entire row/column.

Regards

edit flag offensive delete link more

Comments

The issue is the lack of a keyboard shortcut, not that the functionality isn't present (it's also available under the "Insert" menu). Since there doesn't seem to be any way to assign keyboard shortcuts to toolbar buttons, that's not really a workaround.

stephenb gravatar imagestephenb ( 2016-10-03 18:17:18 +0200 )edit

It is still not possible (AFAIK) to customize this keyboard shortcut but the Insert Rows Above/Below commands can now be assigned to a shortcut.

pierre-yves samyn gravatar imagepierre-yves samyn ( 2016-10-04 08:14:50 +0200 )edit

It's listed as function that a keyboard shortcut can be assigned to, but that's not the issue - it still isn't possible to use the same shortcut as Excel (Ctrl-Shift-+). LO doesn't list that keyboard shortcut at all, even though Ctrl-+ is listed and just about every other possible combination of Ctrl-Shift - except for Ctrl-Shift-+ / Ctrl-Shift-=.

stephenb gravatar imagestephenb ( 2016-12-09 16:26:19 +0200 )edit
0

answered 2018-03-27 20:05:25 +0200

erAck gravatar image

updated 2018-03-27 20:06:42 +0200

As mentioned, Ctrl++ for example is Ctrl+Shift+= on an English keyboard (where + is above =) so you may have to press different keys for your keyboard layout, and it works for me on a Thinkpad without numeric keypad on Linux, LibreOffice 5.3, 5.4 and 6.0.

If it doesn't work on Windows even when taking the keyboard layout into account, it may depend on hardware and Regional Settings, and it might even be only Excel can use it, but it seems even Excel doesn't always recognize it, see https://answers.microsoft.com/en-us/m...

Ctrl++ is bound to Insert Cells, which operates on the current selection. If entire row(s) are selected it inserts rows, if entire column(s) are selected it inserts columns, if another rectangle of cells is selected it inserts cells after asking how to shift the selection.

Anyway, the shortcut can be reassigned under Tools → Customize..., tab Keyboard.

edit flag offensive delete link more
0

answered 2017-06-29 10:51:13 +0200

pipo gravatar image

Ctrl - + and then choose to add a row, but there is no direct shortcut to insert a row above or below

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-01-03 21:08:15 +0200

Seen: 6,453 times

Last updated: Mar 27 '18