Calc: spell checker only recognises Default style language

asked 2016-01-13 17:23:16 +0200

updated 2016-03-10 23:33:58 +0200

Alex Kemp gravatar image

Hi,

for several versions now (I don't remember from which version exactly), "spell checking as you type" in Calc has a serious problem: everything that does not match the rules of the language set in the "Default" cell style ("Font" tab) is treated as an error, i.e. with red underlines.

Example: in the "Default" cell style settings "Italian" is specified in the "Font" tab. All cells with Italian text are treated correctly: errors in the Italian language have the classical red underline, exactly as they should have. Then: other cells have English text, which is also checked against Italian language rules, independently from what is set in the "Font" tab of the "Format Cells" dialogue. Even if a new cell style is defined with "English" as font language, in-line spell checking is always done against the "Default" style font language. Only when running Tools -> Spelling... (F7) the correct language (here: English) is used for spell checking.

The red underlines do not appear immediately after entering the text, but only after switching between sheets or after closing and re-opening the file.

All this is not very nice, especially when writing multi-language tables: only one language has no or few red underlines, while all the other languages are full of red colour...

Some time ago this problem does not exist yet, but, as I said above, I don't remember when.

Somebody knows if there is some trick to get ahead? Or is it simply a bug with which I have to live?

Thank you very much,
Markus

LibreOffice Calc 5.0.4.2 on Microsoft Windows 7 Pro and 8.1
LibreOffice Calc 4.2.3.3 on Linux Mint 17

edit retag flag offensive close merge delete