Ask Your Question
0

Calc spell checker does not work since I cannot set language--WORKAROUND [solved] [closed]

asked 2016-01-16 17:45:58 +0200

updated 2016-03-10 20:38:10 +0200

Alex Kemp gravatar image

Problem. Spell-checker in Calc does not work at all, because I cannot set the spell-check language.

In LibreOffice Writer, when you click Tools --> Language you should see a submenu called "For All Text." Under this menu you can set the spell checker language “for all text” to “English (USA),” so that spell check will work.

However, in my version of Calc (4.4.7.2, on Windows 8.1 at least), there is a bug preventing this from happening. The "For All Text" submenu does not exist. Assuming you have the spell-check dictionaries installed, there is a work-around.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-10 20:37:50.938681

1 Answer

Sort by » oldest newest most voted
0

answered 2016-01-16 17:48:07 +0200

Workaround:

  • Highlight all cells (ctrl + a) → right click → Format Cells → Font → set “Western Text Font” to the language you want to use for spell-check, ex: “English (USA).” The “CTL Font” stands for “Complex Text Layout,” and is used for complex fonts only, such as Arabic, Hebrew, etc. Now that you have set the language, spell-check will work when you click the spell-check button.

To use "Automatic Spell Checking":

  • Next, turn on “Automatic Spell Checking” (ie: auto-underlining spelling errors) by going to Tools → ensure “Automatic Spell Checking” is selected.

    • NB: Automatic Spell Checking is NOT retroactive. This means that if you have spelling errors already on your spreadsheet, they will NOT be underlined now that you selected “Automatic Spell Checking,” rather, only NEW TEXT that you type, from this point on, will be automatically underlined if spelled wrong. Therefore, it is recommended that you now run the spell-checker as normal to check for errors up to this point. Each time you toggle the “Automatic Spell Checking” off then back on, all underlining of miss-spelled words is removed when you uncheck “Automatic Spell Checking,” and is NOT added back when you re-select “Automatic Spell Checking.”
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-01-16 17:45:58 +0200

Seen: 324 times

Last updated: Jan 16 '16