Ask Your Question
0

Calc slows down when increasing rows. Tips??

asked 2016-02-01 21:13:53 +0200

LibreGuy gravatar image

I have a spreadsheet that contains 10 colums and 2500 rows. All of the cells contain quite complicated formulas.

I wanted to increase the amount of rows to 5000, however ... all of a sudden everything becomes very slow. While at first it took only 1 or 2 seconds to save the file, it now takes over 7 minutes!!

Is this "normal" behavior caused by too many cells with formulas, or should I perhaps change one of the (memory) settings or something?

Who can tell me what to do? Or should I just decrease the amount of rows?

edit retag flag offensive close merge delete

Comments

What LO version and what is your GPU ?

rautamiekka gravatar imagerautamiekka ( 2016-02-01 21:28:02 +0200 )edit

I use LO 5.0.4.2 Fresh. GPU Geforce 256MB.

LibreGuy gravatar imageLibreGuy ( 2016-02-01 21:35:19 +0200 )edit

There are many possible reasons why this may be occuring: formula complexity, iterations, OpenCL support, cell formatting. The memory settings mainly relate to graphic handling.

oweng gravatar imageoweng ( 2016-02-01 22:01:07 +0200 )edit

Is there anything I can do about it? Some setting I coud try? Or should I just decrease the amount of rows?

LibreGuy gravatar imageLibreGuy ( 2016-02-01 22:11:36 +0200 )edit

Check my answer. There are absolutely no reasons to decrease the formulas unless it's somehow not optimal, otherwise it's an LO bug.

rautamiekka gravatar imagerautamiekka ( 2016-02-01 22:15:33 +0200 )edit

I'm not sure what you mean. Couldn't it be my processor can't handle it and that's why it takes such a long time?

LibreGuy gravatar imageLibreGuy ( 2016-02-01 22:22:56 +0200 )edit

Another idea is to try and measure how much time certain things are taking just to investigate what might be slow and by how much. As a first stab you could see if half the rows are half as slow. Also you could write a macro to check the CPU time before and after (somehow, I'm not sure w/ your dataset how, but there must be some way) so you could accurately measure how much time it takes to process x rows. Then use this tool to see if there is some threshold size where things slow or not.

EasyTrieve gravatar imageEasyTrieve ( 2017-06-17 16:01:30 +0200 )edit

Also I would think you should try to at least be at LO version 5.2. I'm now using 5.3.3.2 w/o any problems.

EasyTrieve gravatar imageEasyTrieve ( 2017-06-17 16:03:45 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2016-02-01 22:11:07 +0200

updated 2016-02-02 19:51:39 +0200

Since your GPU is so old there's no way it supports OpenCL which is used to accelerate math ops. If you're on Window$ the system could use reinstalling, and LO profile reset might fix or at least improve it.

https://wiki.documentfoundation.org/U... explains how to find the profile. Don't delete, just rename, then start LO and try the problematic parts again.

EDIT 0: LO should auto-detect if OpenCL is supported, but if it fails to detect it properly it'll try running OpenCL which is a big mistake when not supported. Try disabling OpenCL from LO settings before resetting to see if the calculations run faster.

edit flag offensive delete link more

Comments

Thanks, yes, the GPU is quite old but I never have a problem with it. Why should my GPU be doing math ops by the way? Isn't this the task of the processor? If there isn't a setting I can adjust to solve the problem, I think I'll first try to decrease the amount of rows then :(

LibreGuy gravatar imageLibreGuy ( 2016-02-01 22:16:11 +0200 )edit

@LibreGuy, it has to be a bug, either in LO or the GPU drivers. OpenCL was designed to be run on GPUs since they usually outperform CPU in every task both could run, but the GPU has to support OpenCL to use it. Even if yours supported it, it has to be too old or incomplete to cause such problems. Updated answer.

rautamiekka gravatar imagerautamiekka ( 2016-02-02 19:49:18 +0200 )edit

Thanks for the advice. I'm rebuildng and adjusting my spreadsheet right now, hoping for better performance. If the problem continues I will try disabling OpenCL.

LibreGuy gravatar imageLibreGuy ( 2016-02-03 00:26:52 +0200 )edit

Try all of those things before you try to rebuild.

rautamiekka gravatar imagerautamiekka ( 2016-02-03 15:20:05 +0200 )edit
0

answered 2017-06-15 22:50:56 +0200

Francewhoa gravatar image

Hi LibreGuy :) I was facing the same challenge with intermittent slow spreadsheets when increasing rows. I found an easy fix. Which might work for your issue. Steps at https://ask.libreoffice.org/en/questi...

edit flag offensive delete link more
0

answered 2017-06-16 07:04:13 +0200

EasyTrieve gravatar image

updated 2017-06-16 07:04:57 +0200

What hardware gives, software takes. :-)

Have you tried increasing the Cache size in Tools, Options, LibreOffice, Memory?

I'm sure you've already checked that it's only LO that's eating at your CPU, so what about a NVRAM disk, or a faster CPU, or more memory in your box?


BTW, what OS are you on?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-02-01 21:13:53 +0200

Seen: 438 times

Last updated: Jun 16 '17