Ask Your Question
0

Spell checking not working in v3.6.1.2 [closed]

asked 2012-09-28 20:28:14 +0200

yowbooks gravatar image

updated 2015-10-23 05:16:21 +0200

Alex Kemp gravatar image

I'm running Windows7 64-bit Pro and cannot make Libre 3.6.1.2 work with the English USA dictionary, since upgrading. The dictionary for the English USA language does not work. I've tried everything I've seen posted on other threads.

  1. I uninstalled and reinstalled the 3.6.1. That did not work.
  2. I deleted all non-Enlish extensions form C:\Program Files (x86)\LibreOffice 3.6\share\extensions. That did not work.

Using Libreoffice without a spellchecker is like flying blind. I reported this as a bug and was told there is no bug. But every support link the admin gave me was to a legacy version and NOTHING works any more.

So now I am very disheartened by the fact that I now have to reinstall a legacy copy of Word 2000 in order to spell check my documents. This is pathetic.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-23 05:17:36.218732

Comments

(1) Please add the link to your reported bug (fdo#?????). — (2) "...the English USA dictionary...", do you mean the bundled dictionary "dict-en", or an additional dictionary extension?

manj_k gravatar imagemanj_k ( 2012-09-28 21:10:58 +0200 )edit

Hi Manj: Thank you for taking an interest. I was using the default dictionary the comes with Libre. I have a user defined dictionary for other terms. What I really want to do, is to make the default installation work. I'm happy to hose anything else. Thanks, Marshall

yowbooks gravatar imageyowbooks ( 2012-09-29 19:47:41 +0200 )edit

(3) Please have a look at my answer → here; start there with checking the questions (2) and (3), with regard to language English (USA).

manj_k gravatar imagemanj_k ( 2012-09-29 21:11:07 +0200 )edit

Again (1): Would be nice to have the link to your bug report. ;)

manj_k gravatar imagemanj_k ( 2012-09-29 21:14:34 +0200 )edit

Hi Manj_k: The bug report was deleted by someone at Libre. They say there is no bug and referred me to this forum. I tried what you showed. I uninstalled everything, rebooted and installed 3.6.1.2. The dictionary that works is English UK. The English USA is blank. Still screwed.

yowbooks gravatar imageyowbooks ( 2012-10-02 02:48:11 +0200 )edit

(4) "I uninstalled everything,..." — also your LibreOffice user profile? If not: Please → rename your LO user profile.

manj_k gravatar imagemanj_k ( 2012-10-02 21:59:48 +0200 )edit

"The English USA is blank." — That means: missing prefixed blue 'ABC' checkmark symbol?

manj_k gravatar imagemanj_k ( 2012-10-02 22:06:04 +0200 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2013-03-02 16:42:30 +0200

manj_k gravatar image

@ROSt52
(Your question is rather a new question, but I'll try to give a short answer, and to add some related links.)

(1) Tools → Languages → For Selection → More...
That's the correct behavior (there you can select the desired language in the drop-down lists):

format_character_font_language

See also:
(A) fdo#32780 · fdo#36091 · fdo#37919 · fdo#58385,
Specification (OOo): http://www.openoffice.org/specs/appwide/linguistic/
→ Set_Language_Attribute_for_Text.odt
(B) Bug 39793 - UI · FORMATTING: 'Set Language for Paragraph/Selection > More...' should always open the 'Font' tab (dialog 'Character')
(C) fdo#58579, follow-up request for enhancement: Bug 58591 - Setting text language dialogs are misleading

(2) Language guessing tool

@ROSt52: I observed that several lines of text are needed in a selection before the language is selectable under Tools / Language / For Selection

LO tries to detect an undefined language with its "language guessing tool"
(you may open the files "fpdb.conf" and "*.lm" with a text editor;
path: "...\LibreOffice x.y\share\fingerprint\").
(See also: Set_Language_Attribute_for_Text.odt · 1.1.3 Dynamic Language List Generation for Context Menu)

(3) Showing more languages

@ROSt52: I would have expected that Writer shows the installed languages by default when opening: Tools / Languages / For Selection

You may create a paragraph style "Text body xy" for each desired language (Font → Language → xy), save it as a new template, and set it as your default template. Then you should get these languages (in an empty new document) as options in "Tools → Language → ...".

tools_language_selection

See also → [Solved] Tools>Language question

edit flag offensive delete link more
0

answered 2012-10-04 07:45:10 +0200

Using LibreOffice 3.6 with Windows XP for two months now. OpenOffice did a much better job with dictionaries. Could the LibreOffice project team please set up a task force to clear up this serious bug with dictionaries, so that whatever dictionary that is installed works, and whatever language option chosen works and stays that way? Thank you for working on this. Hopefully by version 3.7 this bug would be permanently squashed.

edit flag offensive delete link more

Comments

(1) Spell checking works fine for me (on WinXP) with LibreOffice 3.6.1 / 3.6.2.

manj_k gravatar imagemanj_k ( 2012-10-04 15:22:06 +0200 )edit
manj_k gravatar imagemanj_k ( 2012-10-04 15:30:46 +0200 )edit
0

answered 2013-03-02 06:34:16 +0200

qubit gravatar image

@yowbooks,

What's the bug # of your old bug? I'd like to take a look at why it was "deleted."

If installing the latest release doesn't seem to fix this problem, please file a new bug or update your old one, and provide a list of steps that can reproduce your problem.

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more
0

answered 2013-03-02 12:58:08 +0200

ROSt52 gravatar image

Triggered by this discussion a made a test in writer.

I am running XPprof/SP3 with Asian language support LibO: Version 3.6.5.2 (Build ID: 5b93205) Installed languages: English (default) German, Dutch, Japanese

I typed half a line English / German / Dutch

English is default language and recognized immediately and correct.

I selected German and then Tools / Languages / For Selection but could not select German. The"More" possibility lead to the Character setting window.

I selected Dutch and then Tools / Languages / For Selection got shown Africaans but could not select Dutch. The"More" possibility lead to the Character setting window.

I observed that several lines of text are needed in a selection before the language is selectable under Tools / Language / For Selection

I would have expected that Writer shows the installed languages by default when opening: Tools / Languages / For Selection

Is this a bug or is there more in the background which I don't see yet?

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2012-09-28 20:28:14 +0200

Seen: 1,584 times

Last updated: Mar 02 '13