Ask Your Question
2

How may I do Writer recognize hyperlinks automatically? [closed]

asked 2012-09-29 08:06:08 +0200

mrmister gravatar image

updated 2013-07-15 22:08:11 +0200

manj_k gravatar image

Hello I have a simple but MAJOR problem I need Writer recognize hyperlinks automatically I am attaching to this message a simple TXT file LINKSFILE.txt, without any format and with three internet addresses inside... http://edition.cnn.com/ http://www.nytimes.com/ http://www.usatoday.com/ Okay. What I need to do is you open the TXT file, copy the hyperlinks inside and paste them into Writer. What I need is writer recognize them automatically as hyperlinks, but this, does not happen! when you paste them, you see them as normal text. To make the pasted hyperlinks be recognized as hyperlinks you have to force that. How? just pressing the space bar at the end of each line (adding a simple space) or just pressing the return button. Then, yes, the text is recognized as an hyperlink because Writer analyze it. Well, what I need is this process be done automatically. I get my hyperlinks from a TXT file without format... I paste them in Writer Writer show them automatically underlined as hyperlinks... How may I do this? Is there any way to force Writer to recognize hyperlinks when pasting text without format? If not... could be possible to make a Macro to force the hyperlinks recognition? perhaps adding a single space at the end? or forcing a carriage return? Any idea about this?

I tried to attach a sample TXT file but the attachment button don't work, so I've uploaded a simple TXT file to deposit files, here is the link:

http://depositfiles.com/files/nir8q1jpq

It is a simple TXT file, containing hyperlinks but they are without any kind of format, a TXT so when you open the file and copy the text to paste it into writer, you don't get the hyperlinks recognized. I want to force this recognition in any way?

The reason I need to do this, is because I have a lot of TXT files containing a lot of hyperlinks inside and when I copy the text into writer, they are not recognized as hyperlinks. If I have to press intro, intro, intro, intro, intro, intro, intro, intro, intro, intro, intro, intro, intro, intro, intro... constantly and thouands of times... I could die !!! so I need a solution please...

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-18 03:00:03.922826

2 Answers

Sort by » oldest newest most voted
3

answered 2012-09-29 11:29:11 +0200

manj_k gravatar image

(1)
Menu Tools → AutoCorrect Options... → Options tab →
☑ ☑ URL Recognition

URL Recognition 1

(2)
Paste the text into Writer
Select all (Ctrl+A)
Apply the Paragraph Style "Default"

URL Recognition 2

(3)
Menu Format → AutoCorrect → Apply

URL Recognition 3

edit flag offensive delete link more
0

answered 2012-09-29 15:12:38 +0200

mrmister gravatar image

YOU LITERALLY SAVED MY LIFE. READ THIS PLEASE: THANK YOUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU !!!!! Seriously, a lot of thanks for this.

edit flag offensive delete link more

Comments

I'm happy that your problem could be solved. :)

manj_k gravatar imagemanj_k ( 2012-09-30 13:31:49 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2012-09-29 08:06:08 +0200

Seen: 4,289 times

Last updated: Sep 29 '12