Ask Your Question
0

LibreOffice Ugly after upgrading to 5.1 [closed]

asked 2016-02-12 20:44:45 +0200

Mateus Felipe gravatar image

updated 2016-03-09 12:42:31 +0200

Alex Kemp gravatar image

I have an Arch Linux system with Mate DE, and I'm using Paper theme. snwh.org/paper/ Until 5.0, LibreOffice was ok, but now that my system upgraded it to 5.1 it seems that it tries to use the system theme, and becomes ugly.

Descrição da imagem

There's any way to fix this behaviour?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-09 12:42:59.234936

1 Answer

Sort by » oldest newest most voted
1

answered 2016-02-15 21:56:25 +0200

Mateus Felipe gravatar image

I figured it by myself. It seems that LibreOffice 5.1.0.3 10m0(Build:3) uses GTK3 by default. I don't know if it's intended, as until 5.0 GTK3 was experimental. I solved the problem by editing /etc/profile.d/libreoffice-fresh.sh, uncomenting export SAL_USE_VCLPLUGIN=gtk and rebooting my system. This env var forces LibreOffice to use GTK2, so it worked.

edit flag offensive delete link more

Comments

Is that a fix or more of a temporary workaround until gtk2 becomes unworkable? I ask b/c I am honestly interested. There is a fair bit of work being done at present to move LO to gtk3. Thanks.

oweng gravatar imageoweng ( 2016-02-17 14:49:40 +0200 )edit

Thanks dude!

FishSticks_ gravatar imageFishSticks_ ( 2016-12-06 15:27:24 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2016-02-12 20:44:45 +0200

Seen: 2,028 times

Last updated: Feb 12 '16