Ask Your Question
0

Lead empty cell(s) ignored when copy/pasting

asked 2016-02-19 10:57:08 +0200

desdenova gravatar image

updated 2016-03-08 21:48:17 +0200

Alex Kemp gravatar image

Hello,

I recently switched over to LibreOffice after running into too many issues with OpenOffice... and it did solve all of those annoying problems! So I'm pretty happy about that ;-)

However, I am noticing one odd behavior.

When I copy-paste a row of data from a spreadsheet, if the first cells are empty, when I paste it into say a text editor, instead of using tabs for the empty cells it will just start with the first non-empty cell.

This is consistent no matter where I paste the data -- text editor, browser, etc.

If I type a space into the first empty cell, then it gets copied fine (along with any other empty cells that may follow)... but so does the space, of course, so that's not the ideal workaround.

This is a big issue for me as I regularly need to copy-paste data to and from spreadsheets, and I need those empty cells to be recognized and properly carried over as tabs.

So is there a way I can modify this behavior, via options perhaps? I've looked but couldn't figure it out... and google hasn't been much help either.

Some tech specs:
LibreOffice 5.0.4.2-3.fc23
Fedora 23 with KDE 5.14
Linux kernel 4.3.3

Been racking my brains over this for weeks now, so I'd really appreciate any assistance you could provide. Thanks!

PS. BTW, this is definitely a LO-specific issue, as copy-pasting from Google Spreadsheets works as expected.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-02-06 03:54:51 +0200

I ran into the same problem. Specifically, LibreOffice does not preserve blank rows/columns that are around the text, above, below, left or right. Enter some text in 4 cells in the middle of the screen. Copy the text and several rows and columns around the text. When pasting as rich text, the blank rows/columns are preserved if the destination application supports rich text: Google Sheets, Microsoft Excel, LibreOffice Writer. When pasting as plain text, the blank rows/columns are stripped and only rows/columns that have text are pasted.

Why do you need to preserve blank rows or columns? To keep the tabs as placeholders. As explained above, if you are working with text, deleting the tabs (i.e. blank rows/columns) changes the meaning. For example, let's say you are entering data for each day of the week. The first day, Sunday, and last day, Saturday, doesn't have any data. If you copy the header, Saturday and Sunday will have tabs indicating no data. If you don't copy the headers and only copy the data, Saturday and Sunday will be lost. I.e. the tab placeholders will be stripped.

Is this the way it's supposed to work?

Versions

  1. Google Sheets as of 2018-02-05: Preserves blank rows and columns.
  2. Microsoft Excel: Preserves blank rows above and blank columns to the left. Blank columns to the right and blank rows below the text are stripped.
    • Version 16.9 (180116) on Mac High Sierra
    • Version 1801, build 9001.2138 on Windows 10
  3. LibreOffice Calc on Mac: Blank rows and columns are stripped.
    • Version 6.0.0.3, build ID 64a0f66915f38c6217de274f0aa8e15618924765, 64-bit on Mac High Sierra (10.13.3)
    • Version 6.0.0.3, build ID 64a0f66915f38c6217de274f0aa8e15618924765, 64-bit on Windows 10
    • Version: 5.3.7.2.0+, Build ID: 30m0(Build:2) 64-bit on openSUSE (using the LibreOffice repos)
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-02-19 10:54:06 +0200

Seen: 307 times

Last updated: Feb 06 '18