Ask Your Question
1

How to make the text formatting toolbar permanent in Impress?

asked 2016-02-21 03:54:19 +0200

texasbb gravatar image

updated 2016-03-08 18:42:44 +0200

Alex Kemp gravatar image

As of LibreOffice 5, the Text Formatting toolbar only shows up when you click on some text. Then if you click elsewhere it disappears. This causes frequent (continual!!) redrawing of the screen and resizing of the slide area as that toolbar appears and disappears. Infuriating!!

How do I make the toolbar stay put?

edit retag flag offensive close merge delete

Comments

yes, I have this problem, too. It is very , very annoying! I tried to lock it but it still disappar. when I am not editing a text box. I hope the developers can stop doing this kind of useless but annoying "features". Seriously, please fix it! be For now, I am uninstalling 5.0 and I will go back to 4.4...

Michael Wang gravatar imageMichael Wang ( 2016-04-06 15:30:04 +0200 )edit

I'm having the same issue and would also love to find a solution. As a feature, it would be useful if the editting area did not also resize/shift. I'm sure there must a configuration option to do what I want, but I'm still looking ...

rbenning gravatar imagerbenning ( 2016-06-07 03:05:00 +0200 )edit

I'm having the same issue. I have a small screen and it becomes very difficult to manage even using the workaround given by rbenning..

Vish gravatar imageVish ( 2016-06-15 07:02:55 +0200 )edit

Please this is driving me crazy

davidz123 gravatar imagedavidz123 ( 2017-02-19 15:09:20 +0200 )edit

5 Answers

Sort by » oldest newest most voted
0

answered 2018-08-20 21:38:12 +0200

Easy solution and probably already explained above: Put the dynamic toolbar behind a (new or existing) permanent one.

edit flag offensive delete link more
0

answered 2016-06-07 03:17:49 +0200

rbenning gravatar image

updated 2016-06-07 03:23:53 +0200

Well, within 5 minutes of posting my previous comment, I devised what may be potential workaround. It works for me, and I think is okay as a short term strategy. But as I am fairly new to Libreoffice, I’d certainly like to know how to do this in a more permanent, or more effective manner. To overcome the continuous document resizing as new toolbars appeared, I simply undocked the offending toolbar from the top (or side) of the document screen, and placed it as a floating tool bar over the document window. Now when I select an object, such as a picture, the "Frame" toolbar appears as a floating toolbar, in the last position it was used, nicely placed out of the way of my document. But, the document no longer shifts and things appear to work as normal. I do have the luxury of a large monitor, so this would still be annoying for smaller screens. However, for now, I can live until I find a better solution.

EDIT: be sure to 'save' your document after each toolbar change, or the repositioning behaviour reverts to it's old ways.

edit flag offensive delete link more
0

answered 2017-06-02 16:45:42 +0200

levara gravatar image

Another workaround based on PeterPiper's answer. Create new toolbar as he explained, but don't try to add all of the buttons standard text formatting toolbar has. Even if you add only a single button, you can position it in the second row and add text formatting toolbar after it. Text formatting toolbar will still disappear, but now it won't shift the whole screen because your toolbar is still there. This way your screen won't break and you don't have to add all the necessary command to your toolbar. But you can still add those command that you use frequently.

edit flag offensive delete link more
0

answered 2017-08-19 03:17:55 +0200

updated 2017-08-19 03:19:48 +0200

I just a make a solution for this and feel worthy to share it...I feel the main problem is continuous changing of screen size due disappearing of Text Formatting Toolbar. May be there are few Toolbars which are permanent and few are non-permanent. So if you add one more permanent tab and the Text Formatting Tab then they will interchange when you start editing your text but screen size remain same which reduces the irritating situation.

You can follow the process given below (tested by me): 1. Remove all the Toolbars. 2. Add Standard Toolbar. 3. Add Line and Filling Toolbar.

There is no need to add Text Formatting Toolbar now.

Now if you start editing texts...that Line and Filling Toolbar will be replace by Text Formatting Toolbar automatically. So there will not any fluctuation of screen size...which will reduce the irritating situation.

Hope it will work for everyone...waiting for your feedbacks...enjoy!!!

edit flag offensive delete link more
0

answered 2017-02-12 10:39:18 +0200

I found a way to work around this terrible terrible "feature", though it takes some patience: Create your own toolbar! Yes, it takes quite a few minutes of your time, but in the long run I prefer it this way. Just go to "View/Toolbars/Customize/New", then hit the "Add" button, choose the category "Format" in the left list and then pick any element you need.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

4 followers

Stats

Asked: 2016-02-21 03:54:19 +0200

Seen: 6,954 times

Last updated: Aug 20 '18