Ask Your Question
0

Impress: Unable to display slide show properly on HiDPI machines

asked 2016-02-25 06:38:52 +0200

leekb gravatar image

updated 2016-03-07 21:42:35 +0200

Alex Kemp gravatar image

LibreOffice 5.1.0.3 (x64) on Microsoft Surface Pro 4

Just started trying out LO on Microsoft Surface Pro 4. Many software packages are having problems scaling to the high resolution display of the Pro 4. LO components worked fairly well in this respect. But I may have uncovered a display-related problem in Impress. Whether on single-monitor configuration or dual-monitor configuration the slide show mode did not work properly - in that the slide show screen shows chunky rectangular black or white patches. Slide content is totally illegible.

Has any Surface Pro 4 user reported this before?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
2

answered 2016-02-27 20:39:58 +0200

barnpiece gravatar image

Try disabling hardware acceleration.

Go to Tools/Options and select Libreoffice/View.

Under Graphics Output deselect Use Hardware Acceleration.

Richard

edit flag offensive delete link more

Comments

1

Rich, disabling both hardware acceleration and OpenGL fixed the problem. Thanks.

leekb gravatar imageleekb ( 2016-02-28 09:37:13 +0200 )edit

Excellent! Disabling Use Hardware Acceleration worked for 5.4.1.2 (x64). Thank you.

Ron Moon gravatar imageRon Moon ( 2017-09-22 17:43:02 +0200 )edit
0

answered 2016-02-27 20:05:14 +0200

Hello, I have the same problems on PC. LibreOffice Impress - screen 2560x1440 on Windows 10. Only on full sceen mode. Docs that I receved frequently by mail in pps automatically open with full screen mode. Thanks and excuse my bad english

edit flag offensive delete link more
0

answered 2016-02-26 12:04:36 +0200

oweng gravatar image

List of open bugs for "HiDPI" here and there are none that specifically relate to the issue indicated. Please report a new bug and provide a link to the new report back here. Thanks.

edit flag offensive delete link more

Comments

1

New bug 98217 filed. My report is related/similar to bug 98182 and 97943. This bug might also be occurring on non-HiDPI systems. Preso-mode is the primary function of Impress. For this reason I have marked this bug as Major.

Enabling OpenGL rendering option (Tools-Options-LibreOffice-View) would fix the display defect. However, Impress would crash consistently in no more than 3 advances of the slides.

leekb gravatar imageleekb ( 2016-02-27 08:21:23 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-02-25 06:38:52 +0200

Seen: 5,512 times

Last updated: Feb 28 '16