Ask Your Question
0

How do I force writer to save in ANSI

asked 2016-02-26 13:33:17 +0200

jciconsult gravatar image

updated 2016-02-26 14:17:35 +0200

I am trying to use odfWeave in north america. When I enter R formulas in the writer, sometimes it seems to convert the detault character set to UTF-8 which causes the odfWeave software to fail with locale conflicts because I amk not in an UTF-8 locale. The locale problem also occurs if I insert text in the template and use the default bullet formatting,

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-02-26 18:26:43 +0200

petermau gravatar image

updated 2016-02-27 15:03:32 +0200

By ANSI, do you mean US-ASCII? This is contained in the first 127 characters of Unicode (UTF-8), ISO 8859-1 the first 255. So if you restrict yourself to those characters, you have the equivalent character sets.

You have not said which version of LibO you are using, the language, locale and operating system. These would be helpful. I assume you are using English (USA)

However, ODF in this case LibO writer, uses Unicode (UTF-8), which supports all languages. All languages supported by LibO are consequently supported. The locale is used by LibO to manage defaults like the character set and spelling.

What locale conflicts are you having, with LibO or odfWeave? If it is using ODF, I would expect the software to use Unicode (UTF-8). Of course I may have misunderstood your problem.. Peter

=========

I understand now that ANSI is a Microsoft term for a set of Character sets and is not an actual standard. I assume that the version you are requested is the old Windows-1252 as used in America. This is used in Windows to support legacy systems. I quote from Wikipedia, "The term ANSI as used to signify Windows code pages is a historical reference, but is nowadays a misnomer that continues to persist in the Windows community" . I realise that this does not help your problem but may give you some extra background. What do the odfWeave people say?..Peter

edit flag offensive delete link more

Comments

There are evidently known challenges with getting odfWeave to recognise UTF-8. The solution under GNU/Linux is to set/pass an environment variable. Under Windows it is not so simple, which is probably why ANSI input is being requested.

oweng gravatar imageoweng ( 2016-02-27 13:18:28 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-02-26 13:33:17 +0200

Seen: 622 times

Last updated: Feb 27 '16