Ask Your Question
0

Installation failed because of broken dependencies

asked 2016-03-01 09:40:28 +0200

yltang gravatar image

updated 2016-03-07 14:58:07 +0200

Alex Kemp gravatar image

My Libreoffice (on Ubuntu 14.04 LTS) is broken, so I tried to reinstall it.

Uninstall:

sudo apt-get remove --purge libreoffice*
sudo apt-get clean
sudo apt-get autoremove

And then install again:

sudo apt-get install libreoffice

But I got the following error messages (the wordings are not exact because I am not using the English version):

 libreoffice : dependencies: libreoffice-base but it won't be installed
           dependencies: libreoffice-calc but it won't be installed
           dependencies: libreoffice-core (= 1:4.2.8-0ubuntu4) but it won't be installed
           dependencies: libreoffice-draw but it won't be installed
           dependencies: libreoffice-impress but it won't be installed
           dependencies: libreoffice-math but it won't be installed
           dependencies: libreoffice-report-builder-bin but it won't be installed
           dependencies: libreoffice-writer but it won't be installed
           dependencies: libreoffice-avmedia-backend-gstreamer but it won't be installed
           dependencies: libreoffice-java-common (>= 1:4.2.8~) but it won't be installed
           dependencies: python3-uno (>= 4.0~) but it won't be installed
           Recommend: libreoffice-gnome but it won't be installed or
                   libreoffice-kde but it won't be installed

E: Unable to fix the problem, you have hold broken packages.

How do I reinstall Libreoffice?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-03-02 15:21:07 +0200

petermau gravatar image

You did not say how LibreOffice was broken or what version and language you are using. This way will bypass your current problems.

The way I install LibreOffice is to download and install them from the website. There are other methods but this suits me the best. Choose your version and select the deb files. LibreOffice 5.0.4 still is probably the best for you. When you unpack the main package you will find a README file to give installation advice.

You can download LibreOffice from https://www.libreoffice.org/download/.... There are three packages you need, the base package, your language pack and optionally the help files. You will need to unpack and install them in that order.

I am sure others will have a smarter way to unpick your problem, so I welcome their additions...Good luck.. Peter

edit flag offensive delete link more

Comments

Unfortunately Unity integration relies on the Ubuntu-provided variant of LO, which in this case is v4.2.8. It appears one of gstreamer, java-common, or python3-uno are out of synch with the LO requirements. Whether this is a Ubuntu package/repository issue or LO is difficult to tell, but I would think the former more likely. This is a common occurence where backport (non-canonical) PPAs are used.

oweng gravatar imageoweng ( 2016-03-14 09:21:51 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-03-01 09:40:28 +0200

Seen: 2,288 times

Last updated: Mar 02 '16