Ask Your Question
0

How do I hide the LibreOffice entries from the Applications menu (Debian MATE)?

asked 2016-03-03 17:01:04 +0200

michaelburns gravatar image

updated 2016-03-07 14:43:27 +0200

Alex Kemp gravatar image

I am using the MATE desktop environment in Debian. I do not want LibreOffice displayed in my Applications menu (but I do want to have LibreOffice installed). I have tried editing the .desktop files (which, btw, are scattered throughout the system) by appending the line:

NoDisplay=true

This works for all of the other menu items for other softwares that I wanted to hide, but even after:

for myhiddenlibreoffice in $(find / -name *.desktop -print0 | xargs -0 /bin/grep -l "LibreOffice")

do echo 'NoDisplay=true' >> "${myhiddenlibreoffice}"

done

I still see LibreOffice in my Applications menu. I understand that this may be a MATE desktop issue rather than a LibreOffice issue, but at the very least, LibreOffice is installed into the menu system in a peculiar way (multiple scattered desktop files, doesn't respond to NoDisplay key, stalls computer if I make the mistake of opening one of the menu categories that contains a LibreOffice item), and perhaps someone can explain this "special" implementation for LibreOffice to me.

One last thing, I just want to affirm that LibreOffice is a wonderful software in its own right. We live in a world where people are so lazy that they insist that I must use MS Office to submit a document to them, but at least I can just import and export using LibreOffice, and usually no one is the wiser. It is just so rare that I would ever want to launch LibreOffice for document creation rather than just editing someone else's MS Word document, that I would rather just launch from the command line instead of it getting in the way of my otherwise clean, simple Applications menu.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-03-03 18:03:07 +0200

petermau gravatar image

I use Linux-Mint-Mate 17.3 so I am not certain whether the same considerations apply. It may do if this is a Mate issue.

If I right click on the Applications Name in the Toolbar, I have a option EDIT MENUS. Choose the OFFICE option and the Office Applications are displayed. Unselect the LibreOffice Menus you do not want and they will no longer show on the Applications Toolbar. You will need to repeat this each time you install a new version, or reinstall LibO. I have 4.4, 5.0 and 5.1 installed and select just the one option for 4.4 and 5.1 and all for 5.1. Hope this is relevant...Peter

edit flag offensive delete link more

Comments

Thanks you for the response, Peter. I don't seem to have the EDIT MENUS option that you explained.

michaelburns gravatar imagemichaelburns ( 2016-03-04 14:19:06 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-03-03 17:01:04 +0200

Seen: 260 times

Last updated: Mar 03 '16