Ask Your Question
0

Date entered in Calc does not default to current year [closed]

asked 2012-10-05 23:55:48 +0200

DaMole gravatar image

updated 2015-10-18 15:18:33 +0200

Alex Kemp gravatar image

In newer version 3.6.2 (and other 3.6 versions), the date entered in a cell of a spreadsheet in Calc does NOT default to the current year. Is there a way to change some option to reinstate this default?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-18 15:18:41.736282

Comments

It works fine for me US-english. Can you be a bit more specific ERxpected and what is shows. Stupid question: Is your system time correct?

horst gravatar imagehorst ( 2012-10-06 02:26:18 +0200 )edit

I set the date routinely with an atomic clock free program and date is correct.

DaMole gravatar imageDaMole ( 2012-10-12 00:22:54 +0200 )edit

5 Answers

Sort by » oldest newest most voted
0

answered 2012-10-13 13:08:20 +0200

Jens S gravatar image

updated 2012-10-13 13:09:07 +0200

Try to change the Date Acceptance Patterns box to: M-D;M-D-Y;M-

Jens

edit flag offensive delete link more
0

answered 2012-10-12 00:39:27 +0200

DaMole gravatar image

Thanks to all for response. I checked and confirmed date was correct. I then reinstalled version 3.6.2 (version 3.6.1 had same problem). I have been using version 3.5.6 and earlier 3.5 version without problem. I checked Options and the date range was set to 1930-2026. I then did some searching after mariosv's suggestion. The date I tried in a cell was showing '10/5/2012' from a previous use in a version 3.5.2 Calc. In the latest version, I entered '10-11' for today and the cell then showed just '10-11' with no year. I then found in Options>LanguageSettings/Language that the parameter for Date Acceptance Patterns was set to 'M/D/Y;M/D'. Going back to the test cell, I entered 10/11 (using the forward slash rather than dash) and it correctly showed '10/11/2012'. Does anyone know if there is a way of changing the values in the Date Acceptance Patterns box. I tried adding 'M/D/Y;M/D;M-D' but still did not take M-D entered with dash. All previous versions would accept the M-D (with dash rather than slash) format and show the date for the current year. I will just have to get use to using the M/D (with slash) format. Thanks again for help.

edit flag offensive delete link more
0

answered 2012-10-07 08:22:48 +0200

Mine also works in the US-English running on Linux-Mint 13 Mate edition.

Check to see if the LibreOffice "options" are set to 1930-2026. Go to The Tools menu, Options. On the left expand "LibreOffice" and choose the General option and check that the program is set up to use 1930 - 2026. This may not have any effect but I can't think of anything else without some further information. What OS are you running this on?

edit flag offensive delete link more
0

answered 2012-10-06 01:21:36 +0200

m.a.riosv gravatar image

updated 2012-10-06 01:22:00 +0200

Maybe the issue is related with the more strict control to input dates in 3.6.

I think you need to used your locale date separator to enter the date.

edit flag offensive delete link more
0

answered 2012-10-12 02:54:53 +0200

m.a.riosv gravatar image

Information about it, here:

https://gerrit.libreoffice.org/#/c/511/

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-10-05 23:55:48 +0200

Seen: 624 times

Last updated: Oct 13 '12