Ask Your Question
0

Libre Office Crashes at first launch every time for every user

asked 2016-03-23 20:51:08 +0100

dbkr2020 gravatar image

At first launch for any user on my Citrix server running Windows Server 2008 R2, the application crashes. The event that occurs is below. If you click close and then launch the app (word or calc or whatever) it launches fine after the initial crash. Only happens the first launch on a fresh profile, if you've launched the app before and clicked through the error and have a profile, you're good to go. Any fixes? Suggestions?

Faulting application name: soffice.bin, version: 5.1.1.3, time stamp: 0x56d4f99a Faulting module name: KERNELBASE.dll, version: 6.1.7601.18933, time stamp: 0x55a6a16f Exception code: 0x00000000 Fault offset: 0x000000000000b3dd Faulting process id: 0x25ec Faulting application start time: 0x01d1853be1606c62 Faulting application path: C:\Program Files\LibreOffice 5\program\soffice.bin Faulting module path: C:\Windows\system32\KERNELBASE.dll Report Id: 201cc306-f12f-11e5-b243-001dd8b71f73

edit retag flag offensive close merge delete

Comments

Same/similar issue was once reported early in v4 series (tdf#65336) without resolution. Some comments near the end of this MSDN Social thread seem to indicate it may be permission-related.

oweng gravatar imageoweng ( 2016-03-23 21:52:53 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-05-05 20:21:11 +0100

joseph_robert_martinez gravatar image

As an administrator, the only reason I would install applications on a server would be for the antivirus and similar to be able to correctly identify files saved on the machine.

Also, my users would not be directly nor remotely accessing the server, for the fact that something may go wrong. Now, if you have this application installed on the server, so that you only have to install one copy, instead of on each machine, I would suggest to you to do the latter. While Citrix's purpose is to allow a multi-user environment, most office suite applications are designed to be user specific/concentric. Meaning, each user has their own set of config/preference files, even for the most basic of programs. LO being one of them. What could be happening is that LO is trying to install new user config files, but somebody else's is already there, as XenDesktop clones a default profile, then pushes it out to the end user. So updating/upgrading LO to the latest version will always have this issue.

Now the link for the MSDN has reference that this could be a 32bit vs 64bit, that should not be an issue. This would go back to how your Citrix server is set up. Are the apps being run on the local machine or the server? WinSvr20089R2 is 64bit and as long as the app is running on the server, the cpu on the local machine could care less if it was a 64bit program or not. But, if the Citrix server is set up to do a hybrid style, where the apps/files/programs were stored on the server, but run on the local, that could be a problem.

What ever the case, with out specifications on how your Citrix is setup, plus being out of scope, I do not think that you are going to get your answer here.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-03-23 20:51:08 +0100

Seen: 830 times

Last updated: May 05 '16