Ask Your Question
1

How to deactivate automatic date formatting in calc? [closed]

asked 2012-02-29 11:45:32 +0200

laxas gravatar image

How can I deactivate the automatic date formatting when I paste numbers from writer to calc. 1.1, 1.2, 2.1 ... are falsely converted to dates. I am using the localised (German) version of LibreOffice.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-19 19:48:31.008504

Comments

Hi @laxas, Did you ever find a satisfactory answer to your problem? If not, perhaps you could tag your question as a feature-request?

qubit gravatar imagequbit ( 2013-01-20 21:37:20 +0200 )edit

5 Answers

Sort by » oldest newest most voted
2

answered 2012-02-29 18:39:42 +0200

erAck gravatar image

Before pasting from the clipboard assign the number format Text to the cells to be pasted on. For manual input the input can be preceded with a ' single quote character. Both methods force the input to text and not be interpreted.

LibO 3.6.0 will act differently based on locale dependent date acceptance patterns for incomplete dates, e.g. in a German de_DE locale 1.2 would not yield a date, only 1.2. would.

edit flag offensive delete link more

Comments

1

Pre-Formatting the cells is not working (LO 3.3.4). However, I found another way: "paste content" ("Inhalt einfügen") and deciding for "unformatted text" is working. It is still disappointing that the auto-formating can't be turned off.

laxas gravatar imagelaxas ( 2012-03-13 09:21:17 +0200 )edit
0

answered 2012-09-16 00:14:28 +0200

m.a.riosv gravatar image

If you import with paste unformatted text, you can select the format, while in the import box, click the header of the column and in the upper box select the format.

image description

edit flag offensive delete link more
0

answered 2012-02-29 16:51:58 +0200

Your current default language most likely uses the dot "." as a separator for dates.

You can specify this in Tools>Options>Language settings>Languages, by setting Decimal separator key to Same as locale setting (or not: experiment to see what's best for you).

edit flag offensive delete link more

Comments

I tried that now. However, it didn't change anything. The ordinal numbers which I try to paste (1.1; 1.2; ...) are interpreted as dates (e. g. 01.02.2012) not as decimal numbers.

laxas gravatar imagelaxas ( 2012-02-29 17:47:56 +0200 )edit
0

answered 2012-09-15 23:13:28 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

It is really a stupidly predefined behavior. I use Calc regularly, but I do only in the rarest situation use dates. It is very annoying to be forced in a new sheet to format cells. The natural content of a cell is a number. Anything else should be set by the user.

edit flag offensive delete link more
0

answered 2013-01-03 18:12:00 +0200

erAck gravatar image

Note that as of LibreOffice 3.6.2 the date recognition is more strict and depends on locale specific patterns and you can also define the date acceptance patterns, see https://wiki.documentfoundation.org/ReleaseNotes/3.6#Localization

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-02-29 11:45:32 +0200

Seen: 8,335 times

Last updated: Jan 03 '13