Ask Your Question
0

I cannot type "01:10:", "01:11:" or "01:12:"

asked 2016-04-01 00:27:57 +0200

Adlard gravatar image

updated 2016-04-01 21:43:57 +0200

Hello, everyone.

I want to type the following content in a Calc cell:

01:12:56

However, when I type the colon after "12" the whole content goes back to "01". The same thing occurs with the numbers 10 and 11. I've tried turning off AutoCalculate and AutoInput, but it did not work. I have also deleted some entries in the Replace section of the AutoCorrect options, but I still could not solve the problem. This error happens with different types of cell formats.

Thank you all in advance.

I apologize for any spelling/grammatical mistake in the text, since I am not a native English Speaker.

EDIT [April 1st, 2016]:

@Lupp @moshe11 @w_whalley

Hello, everyone. Thanks for helping me out, but I have already solved my problem.

The problem was really with the replacements options. I had deleted some entries in the Spanish dictionary, but some other dictionaries had these same entries. Since deleting these entries in all of the other dictionaries would take me some time, I just chose [None] as the default language for documents following the instructions on this topic:

https://ask.libreoffice.org/en/questi...

However, I found out that I could also have solved the problem by disabling the autoreplacement feature in the AutoCorrect options (Tools - AutoCorrect Options - Options - Uncheck "Use replacement table"). It's simple and easy.

Anyway, thank you all very much, guys :)

edit retag flag offensive close merge delete

Comments

Did you read my answer and my comment to the answer by moshe11? Why don't yot tell your version and locale? I may hope that the bug only is present in V5.1.2.1 It did not show in V4.5 nor in 5.0.

Lupp gravatar imageLupp ( 2016-04-01 02:06:37 +0200 )edit

I'm using win7 , LibreOffice Version: 5.0.5.2 , and i can not reproduce this problem .

So , i thought it is some simple mistake by the user Adlard .

But , if you can make the mistake happen in your p.c as well , then it is probably a problem in the software .

I included the info about my p.c , hope it will help somehow .

moshe11 gravatar imagemoshe11 ( 2016-04-01 02:44:57 +0200 )edit

@moshe11: Thanks! This is backing my suspicion that the issue is a regression bug in V5.1. (or just 5.1.2).
@Adlard: It will be helpful if you also complete the information with the LibO version and the OS you were using. I will file a bug report about this then.

Lupp gravatar imageLupp ( 2016-04-01 13:50:16 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2016-04-02 22:13:56 +0200

horst gravatar image

Hi all guys, this NOT a bug it is a feature. The construct :emoji: was introduced in 5.0 to insert symbols as soon as you type the 2. colon, avoiding the blank. The symbols :10:, :11:, :12: are little clock with hands at that time, but they are only available in some fonts, most fonts will show only nothing or a little box.

edit flag offensive delete link more

Comments

I may look rather silly now, But I actually did not change my settings for a few months: 'Use replacement table' is ON. The replacements for entered strings containing a colon are deleted. Under these settings I got exactly what I described in my first comment to the answer by @moshe11.. Now I cannot reproduce this behaviour. Any Idea?
(What is the emoticon for "I dislike emoticons"?)

Lupp gravatar imageLupp ( 2016-04-03 20:57:07 +0200 )edit

It may be a feature, but it's a poorly thought out one. Calc time format, for example: hh:mm:ss. Every time the minute is 10, 11, 12... yeah that's annoying. I replaced them locally with ::10::, ::11::, and ::12::, though maybe something like :clock10:, :clock11:, :clock12: would be more consistent with the emoji format.

szurcher gravatar imageszurcher ( 2016-07-16 03:10:16 +0200 )edit
0

answered 2016-04-01 01:11:24 +0200

Lupp gravatar image

updated 2016-04-01 15:23:56 +0200

With LibO5.1.2.1 Calc under Win 8.1 I can reproduce the issue. It is clearly a bug IMO, but I cannot even guess by what it might be caused. If you report the bug to this site, place cross links here and there, please.

Your LibO version, UI language, locale? Your OS?

Edit 1
@Adlard: Please provide additional information: Your LibO version and your O perating S ystem.

Edit 2
To prepare a bug report I meanwhile made some additional tests, among them to make a backup of the user profile and then to reset it. The bug vanished.
Conclusion: The bug may occur if the user profile is corrupted in a specific way. It was a strange thing that it occurred on my system and on the system of the OP as well.
Then I reinstated the user profile first saved as a backup.
Very strange: The bug did not show again. I am perplexed now because I have not the slightest idea about a possible background of this behaviour. There is little sense in a report about a bug I cannot reproduce myself.
If there will be something new with this respect, I will report here again. Sorry!

edit flag offensive delete link more
0

answered 2016-04-01 01:04:05 +0200

moshe11 gravatar image

Calc thinks you write the time .

so , when you write 01:12: , it adds the seconds and writes 01:12:00 .

But maybe your column is too narrow , and you only see "01" .

Try to widen the column to see all the text .

If you want to write the text : 01:12:

(and you don't want Calc to treat it like time) ,

add a ' before your text , like this ---> '01:12: .

edit flag offensive delete link more

Comments

The bug is real. I verified. Entering all the keystrokes for 01:12:56 we get a string of length 6 containing two exotic unicode characters (U+D83D, U+DD5A) in the third and the fourth place where the four characters of :12: should be (which obviously are replaced for display by only one placeholder).
With what version did you (moshe11) get your results?

Lupp gravatar imageLupp ( 2016-04-01 01:16:37 +0200 )edit

Hi! Thanks for replying :)

"so , when you write 01:12: , it adds the seconds and writes 01:12:00"

Actually, I cannot type "01:12:" I can only type "01:12" (without the second colon). The software changes the content just after I type the second colon.

"But maybe your column is too narrow , and you only see '01' ''

In this case, the LibreOffice would probably give some "###", I believe. "add a ' before your text , like this ---> '01:12:" I tried that as well, but it did not work. :/

Adlard gravatar imageAdlard ( 2016-04-01 01:38:15 +0200 )edit

In Tools/AutoCorrect the strings :10:, :11:, :12: are replaced by a character or character that I cannot read. It also happens with the strings :1:, :2:, etc. A work around is to hit Ctrl-Z as soon as the unwanted replacement happens. A permanent solution is to delete those unwanted replacements in the AutoCorrect Replace table.

w_whalley gravatar imagew_whalley ( 2016-04-01 01:47:04 +0200 )edit

The 1:12. (e.g. or the :12: therein) is not replaced with something from the replacement table, but with the two far-off unicode characters I already mentioned. Did someone read my answer and my comment? I actually tested and investigated!

Lupp gravatar imageLupp ( 2016-04-01 02:02:19 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-04-01 00:27:57 +0200

Seen: 537 times

Last updated: Apr 02 '16