Ask Your Question
0

How do I make LibreOffice my default office suite in windows 10

asked 2016-04-02 19:49:45 +0100

navsert gravatar image

updated 2020-07-15 10:24:41 +0100

Alex Kemp gravatar image

How do I make LibreOffice my default office suite in windows 10

edit retag flag offensive close merge delete

Comments

This question was asked in 2016, the last response was 2018 and the suggestions do not apply to Windows in 2020. Microsoft was sued as anti-competitive for not allowing other web browsers on platform. We are unable to make LO a default on Windows. Am I wrong? Is it time for a GoFundMe lawsuit?

gcord62 gravatar imagegcord62 ( 2020-05-28 12:50:55 +0100 )edit

8 Answers

Sort by » oldest newest most voted
2

answered 2020-08-30 14:23:58 +0100

math20 gravatar image

On Win 10 go to Settings > in the search window Find a setting type default apps > will show a panel on the right with a list Choose default apps > scroll down and click on Choose default apps by file type > will show file types in alphabetical order > scroll down until you get to the file type for which you want LibreOffice to be the default app, eg docx may show word by default > click, will show a menu where the LibreOffice Writer option should appear > choose LibreOffice Writer as default app to open eg your docx files. Works for many other filetypes that can be handled by LibreOffice applications.

edit flag offensive delete link more

Comments

This was great. Thanks.

Gregory gravatar imageGregory ( 2021-02-10 21:02:46 +0100 )edit
0

answered 2016-04-04 00:07:03 +0100

Try: Settings -> System -> Default apps -> (at bottom of right pane) Set defaults by apps -> pick LibreOffice -> Select "Set this program as default"

edit flag offensive delete link more

Comments

this has worked for me still now Aug.2020

math20 gravatar imagemath20 ( 2020-08-30 14:12:52 +0100 )edit
0

answered 2017-01-19 20:19:09 +0100

KMMo gravatar image

Agree with this answer but you also must go down to the SET DEFAULTS BY APP section and find Libre Office and then click on the option you want - either use it fall all file types it can open or selct just the file types you want it to open.

edit flag offensive delete link more
0

answered 2018-01-04 15:24:59 +0100

updated 2018-01-04 15:26:21 +0100

Since the new Windows Fall Creator Update, this process no longer works. The "Set Defaults By App" option no longer exists as it did before. You cannot just pick a program and have it automatically change all related file associations. You have to pick the program and change the association of each and every file extension MANUALLY! It's a pain in the butt! Does anyone have a workaround for this that will still allow us to change all related file extensions for a given program?

edit flag offensive delete link more
0

answered 2018-04-26 08:23:16 +0100

Hi,

I agree with Rydawg3's answer. In W10's file/app association menu, the association with LibreOffice doesn't work (the menu is presented again after selection). The method proposed by Rydawg3 doesn't work as well if we tend to associate the file with a specific program of LibreOffice (e.g. LibreOffice Writer). We must choose "LibreOffice". The proof is that in the properties box of the choosen document, LibreOffice appears as the opening app (previously, it showed "no application" (or so, I'm French...)). The interesting point is that the association is then performed for all files of the chosen type on the computer (.odt if you started with a Writer document). We need then to repeat the process for the other types of douments (if you started with an odt document, you must repeat the operation with one ods document, etc A bit Strange ....

This applies to LO 5.4.5.1 Build ID: 79c9829dd5d8054ec39a82dc51cd9eff340dbee8

Hope it will help

edit flag offensive delete link more
0

answered 2018-05-26 03:10:21 +0100

For windows 10, right click on any document, select properties, click on change and select your libre office program.

edit flag offensive delete link more
0

answered 2018-08-27 19:51:03 +0100

Dunstan gravatar image

Here is what worked for me in Windows 10:

I right clicked a document file, chose 'Properties.'

found 'Opens With,' and clicked on 'Change'. After selecting the corresponding LibreOffice file type (i.e. Calc for Excel) I found that every example of that file type will now be opened in my computer by Libre. ...I'm hoping this lasts through a reboot.

edit flag offensive delete link more
0

answered 2018-03-06 15:10:05 +0100

this worked for me :

In the Finder, right-click or Control-click on one of your Microsoft Office documents such as foo.doc, foo.xls, etc. In the popup menu that appears, select the Get Info menu item. Click on the disclosure triangle next to Open with: to expand that section. Choose NeoOffice from the dropdown list. Click the Change All button and OK in the dialogue that appears.

hope that helps

edit flag offensive delete link more

Comments

This is driving me mad and wasting a lot if time as W10 always defaults to MS for existing LibreOffice files I have transferred from old XP machine. On existing files "Open with" works and hopefully is remembered but for new files I have to create an MS file and change the suffix to .ods or .odt. I don't understand where to find the "popup menu/Get info" referred to above.

Barak gravatar imageBarak ( 2018-08-12 00:40:50 +0100 )edit

I think that's for Macs.

floris v gravatar imagefloris v ( 2018-08-27 22:55:37 +0100 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-04-02 19:49:45 +0100

Seen: 22,923 times

Last updated: Aug 30 '20