Ask Your Question
0

How to make drawings pasted from Autocad print not dimmed?

asked 2016-04-03 17:06:43 +0200

ARX gravatar image

On Windows 8, when I copy a small drawing from Autocad into LibreOffice Writer 5.0.2, the picture looks fine on the screen. However, when I print the document, although all surrounding text prints normally on paper, the drawing appears very dim. It's there, but you can barely see it.

This problem does not occur if I paste the exact same drawing on MS Word. Everything, text and drawing prints fine. Also, drawings pasted from LibreOffice Draw do not have this problem. So, it is neither a printer nor Autocad problem. Rather, it's the way LibreOffice Writer handles vector graphics pasted from other applications.

I have not been able to find any setting that controls printing of embedded drawings. Is there any way to remedy this?

edit retag flag offensive close merge delete

Comments

Does "dim" mean the lines are so thin they are barely visible, or does a thick line or area print paler than expected? It is likely a vector format handling issue with LO as suggested. Try exporting from AutoCAD to SVG and see if inserting the SVG offers any improvement.

oweng gravatar imageoweng ( 2016-04-04 01:59:18 +0200 )edit

Unfortunately, Autodesk is like MS in their carelessness about compatibility. Believe it or not, they give you no way to export to SVG; only to DWF, which LO doesn't understand. But your comment led me in the right direction of trying an intermediary application to do the conversion, or somehow "fix" the drawing. LO Draw happened to be that application. Thanks for the guidance!

ARX gravatar imageARX ( 2016-04-11 02:46:02 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2016-04-11 02:39:17 +0200

ARX gravatar image

Solved. It turns out that when vector graphics from other applications are pasted into any LO program, there's a setting of the graphic called "Color Mode" that is automatically set to "Default". This makes a wireframe vector graphic (like an Autocad drawing) which is essentially a black and white graphic, to be treated as a color or grayscale graphic.

Once pasted, on the screen the drawing displays normally. You don't see any difference, but when you print it on a printer that has no color cartridges (like mine), the drawing appears dimmed. A line that should be solid black is printed as a pale, irregularly dotted, almost imperceptible, gray line.

If you paste the drawing on LO Writer, there is absolutely no way to change the color mode. You are stuck with the dimmed drawing. The solution I have found is to paste the drawing on LO Draw. Fortunately, the Properties sidebar (when you click the drawing) displays a section called "Graphics" in which there is a drop down option that allows to change the color mode from "Default" to "Black and White".

The modified graphic can then be copied and pasted in LO Writer. And It will print fine.

However, this solution looks like sort of a hack. I'd like to advise the LO developers to include in other applications of the LO suite, besides Draw, the option to change the color mode of embedded graphics. This is really needed to spare your users some frustration and lots of time digging around for a solution to this (I need to repeat here what I stated in the question: this does not occur in MS Word; hence my utter confusion).

In my case, I was lucky to find this workaround. Other people attempting to migrate from MS Office may go the easy way of just saying: "Oops, I can do my stuff in MS Office; I can't in LibreOffice". And they would miss all the awesomeness that LO has to offer. Should not happen!

edit flag offensive delete link more

Comments

Thanks for the detailed report. It appears bug tdf#68069 and tdf#87396 are related.

oweng gravatar imageoweng ( 2016-04-11 02:52:36 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-04-03 17:06:43 +0200

Seen: 156 times

Last updated: Apr 11 '16