Ask Your Question
0

After upgrade to LibreOffice 5 print options are grayed out

asked 2016-05-02 23:53:25 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

My page printer (which is the default printer) works fine. But the print options for my label printer (Brother QL-500) are grayed out and this prevents me from choosing Landscape orientation, necessary for the labels to print correctly.

I've tried removing the config files left in place from LibreOffice 4 and also the trick about "Use only paper tray from printer preferences" but neither move brought the print options back to life.

Any other ideas about how to correct this issue?

Thanks.

       Don
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-05-07 16:08:41 +0100

donkaron gravatar image

updated 2016-05-12 21:45:17 +0100

A correction: paper orientation choices on my default printer are also grayed out.

Prior users have suggested toggling "Use only paper size from printer preferences" (as opposed to paper orientation) but this did correct the problem for me.

And now, somewhat later:

By exhaustive trial and error, I've got it working although I haven't solved the reason it went bad it the first place.

Here's what worked for me:

I'm using Ubuntu 16.04 LTS and my label printer is a Brother QL-500. Far as I know, all Brother label printers use the same driver (available at http://www.diku.dk/~panic/P-touch/).

In Ubuntu System Settings > Printers > Brother-QL-500 > Printer Options Uncheck "Concatenate Pages" or your label will not fully advance after printing.

In LibreOfficeWriter, I used Ctrl-P to bring up the print dialogue. Select the label printer. Click "options" tab. Check "Use only paper size from printer preferences". Click "General" tab > Properties button and the Portrait/Landscape option should be re-enabled.

However, instead of printing what's in the upper left corner of the page, which is where I'd placed the label text, it now prints the middle of the page. So I moved my label text down about 23 lines and tabbed over. (I don't know why the change occurred. I'm sure there're some settings in LibreOffice printing defaults that I can fool with but I haven't found them yet. I'm working on this.) And, behold!, the labels print.

Admittedly a bit of a pain in the rear. Next time I buy a label printer I'll be careful to shop for one with full Ubuntu compatibility, if such a one exists.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-05-02 23:53:25 +0100

Seen: 1,006 times

Last updated: May 12 '16