Ask Your Question
0

Problem saving docx file [closed]

asked 2016-05-04 04:10:42 +0200

genterminl gravatar image

I received a docx file, so I could fill in some information and return it. "file" tells me the original is "Microsofw Word 2007+". If I open it and save it without making any changes, it is now about 30% smaller, and file says "OOXML". If I then make some changes and try to save again, I get "Error saving the document X2: Write Error. The file could not be written." All these saves are as "Microsoft Word 2007-2013 XML (.docx)" I can save the original as ods, but when I later save it as docx, I run into the same problem.

I have full read/write permissions on all files (under my home directory) as well as in /tmp, so it is unlikely a permission issue. This is LibreOffice 5.0.5.2, Build ID: Gentoo official package (Gentoo linux) Locale: en-SS (en_US.UTF-8).

The other odd thing I noticed is that once I get this error, the main document window no longer responds at all. I can select menu items or show/hide the various side bars, but the main document window just gets more and more cluttered with whatever overwrites it, until I close the document. I suppose I am grateful that I can do that, and not have to kill LibreOffice totally.

The one thing I suspect might be an issue is that the document has change tracking turned on. This is just a suspicion, with no real evidence to support it. Unfortunately, I cannot provide a copy of the file, since it has corporate information, but I'll try to get a sample I can release that still shows the problem.

I'd love either an explanation, or at least suggestions on further troubleshooting, or other information I can provide. I've seen a number of posts with this error, but no definite solutions.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by genterminl
close date 2017-05-30 21:48:24.489735

1 Answer

Sort by » oldest newest most voted
0

answered 2017-03-27 14:23:06 +0200

JohnHa gravatar image

updated 2017-03-27 15:04:22 +0200

Go to Tools > Options > Load/Save > General ..., and tick the box "Warn when not saving in ODF or default format". Now read the warning which pops up when you save as a .docx file.

Always work in, and save, all documents as .odt, .ods etc and never as .doc, .docx, .xls etc. There is not, and never will be, 100% compatibility between LO Writer and MS Word, or between ODT files and MS Word files. If you save a MS Word files you will almost certainly lose stuff.

There have been numerous reports about problems exchanging a file with tracked changes between LO and MS Word.

edit flag offensive delete link more

Comments

@JohnHa: Please pay attention what problem you are addressing when you give your (otherwise correct) "Do not use foreign formats" advise. This question is not only about "inexact import/export", it's about a bug that something causes errors reading/writing, which surely needs proper bug report and eventual fixing.

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-27 15:10:43 +0200 )edit

As Mike said, your answer is completely irrelevant to my problem, not to mention a year late. I did not ask about compatability. I asked about an error message. I just tried this again with LO 5.2.7.2, and am able to repeatedly save the file as docx without errors. So - I figure this got fixed somewhere along the line. I'm going to close the question as resolved, with no explanation as to what the actual error was.

genterminl gravatar imagegenterminl ( 2017-05-30 21:47:43 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2016-05-04 04:10:42 +0200

Seen: 1,549 times

Last updated: Mar 27 '17