Ask Your Question
0

Calc: active cell not highlighted or bordered

asked 2016-05-05 13:16:20 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi all,

I recently upgraded to Ubuntu 16.04 and Libreoffice got updated too to the following version: Version: 5.1.2.2 Build ID: 1:5.1.2-0ubuntu1 CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; Locale: en-IE (en_IE.UTF-8)

Everything works fine in Cal, except for the current or active cell: there is no border for the active cell, so it's very hard to work with it. I've tried downgrading Libreoffice to 5.0.5, but same problem applies there.

I've never fiddled with colour schemes and I've also deleted my profile data in ~/.config/libreoffice, but to no avail.

Any suggestions please?

Regards Xserty

edit retag flag offensive close merge delete

Comments

Can you please post your video card model (you can take it from lspci -v and the exact numbers from lspci -n) and your video driver (also from lspci -v) please?

alvarezp gravatar imagealvarezp ( 2016-05-06 22:41:21 +0200 )edit

7 Answers

Sort by » oldest newest most voted
0

answered 2016-05-08 09:07:08 +0200

alvarezp gravatar image

I had the same problem too and it turned out that I had a driver issue on my system. I was using modesetting+vesa+fbdev but my X.org intel driver was missing. Reinstalling the xserver-xorg-video-intel driver helped. You can find further information in a bug I raised against LibreOffice, where other testers couldn't reproduce the problem:

https://bugs.documentfoundation.org/s...

edit flag offensive delete link more

Comments

Thanks alvarezp! This was actually the problem! Or should I say the solution to the problem! Regards, Xserty

xserty gravatar imagexserty ( 2016-05-10 11:49:03 +0200 )edit
0

answered 2017-07-16 22:14:41 +0200

This is not an answer. It's more of a Me Too! Dual Core intel 2ghz running Ubuntu 16.04 LTS. I followed the advice to use the intel graphics update tool. This did not resolve the issue. Running Libre Office 5.1.6.2

This one silly issue is making it exceedingly difficult to complete a migration off of windows.

Thanks for any advice.

edit flag offensive delete link more
0

answered 2017-07-13 09:27:25 +0200

This bus appear in libreoffice 5.1.2, 5.1.6~rc2, 5.3.3~rc2 Xubuntu 16.04.2 aptitude reinstall xserver-xorg-video-intel-hwe-16.04 did not help

edit flag offensive delete link more
0

answered 2017-01-28 21:33:34 +0200

I have the same problem on Ubuntu 16.10 for Calc 5.2.5.1 .

edit flag offensive delete link more
0

answered 2016-05-05 15:32:21 +0200

Lupp gravatar image

updated 2016-05-07 11:41:28 +0200

Did you turn off 'Use OpenGL for all rendering'?

Edit with respect to the comment:
Sorry! I put it wrongly. My intention was to give a hint that an OpenGL issue might be the cause of the malfunction, and to turn OpenGL rendering OFF to get things working better. I have no idea concerning another possible cause...

...except: A corrupted user profile is known to be a possible cause for very strange behaviour of LibO. Try to reset your user profile. Be careful and follow the steps as described here.

Edit with respect to the comments: Sorry! I have no idea beyond this.

edit flag offensive delete link more

Comments

The same happens to me. I turned on OpenGL and the active cell gets marked but the UI breaks really bad that I have to disable it again.

alvarezp gravatar imagealvarezp ( 2016-05-06 10:23:02 +0200 )edit

Clean profile didn't help either. It's weird that OpenGL makes a difference on my system (even if it becomes unusable). [Edit] The OP confirms that clean profile doesn't help form him either.

alvarezp gravatar imagealvarezp ( 2016-05-06 22:39:17 +0200 )edit
0

answered 2016-05-10 11:51:58 +0200

xserty gravatar image

Hi, thank you to all that contributed. I can confirm that inmy particular case, fiddling with OpenGL options fixed the active cell border issue, but rendered the whole Calc unusable and unstable. I've found that the solution provided by alvarezp resolved the problem completely. Thanks again alvarezp! ;) Regards, Xserty

edit flag offensive delete link more
0

answered 2016-12-08 09:18:52 +0200

Unfortunately i've got the same error and

sudo apt-get install --reinstall xserver-xorg-video-intel

and rebooting did not help :/

Activating OpenGL Rendering brings back the Active-Cell-Border but destroys many other Elements. Any Ideas?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-05-05 13:16:20 +0200

Seen: 1,819 times

Last updated: Jul 16