Ask Your Question
0

possible bug in libreoffice 5.1.2.2 with pivot tables

asked 2016-05-20 20:48:51 +0200

laimaretto gravatar image

Hi All, I'm struggling to create and work with pivot tables in LO 5.1.2.2.

When ever I create a pivot table (Insert -> Pivot Table) I can not then drag and drop the fields when trying to edit the layout.

It's impossible to achieve it.

I'm using LO 5.1.2.2 that came with Ubuntu 16.04.

lucas@test:~$ apt-cache policy libreoffice
libreoffice:
  Installed: (none)
  Candidate: 1:5.1.2-0ubuntu1
  Version table:
     1:5.1.2-0ubuntu1 500
        500 http://ar.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

lucas@test:~$ lsb_release -a
No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu 16.04 LTS
Release:    16.04
Codename:    xenial

Is anyone else experiencing this? I've read this [1] already mentioning the bug, but it seems it has not yet been solved.... :-(

Thanks!

Lucas

[1] - https://lists.debian.org/debian-openo...

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-05-20 23:02:42 +0200

LKeithJordan gravatar image

I'm running LO Version 5.1.2.2 on Windows 7 and LO Version 5.1.3.2 on Linux Mint 17.3. I just opened two different existing Calc workbooks, one on each machine, and tried a drag-and-drop on pivot tables they contained. In both cases, I appeared to have no problem.

I recommend you try uninstalling and reinstalling LO. Perhaps there was a problem in the initial install.

Please click the check mark next to the response you believe best answers your question.

edit flag offensive delete link more

Comments

So, I've followed your idea: I've reinstalled LO that comes with Ubuntu and now the problem is gone. I can now edit the layout of pivot-tables anyway I want. It's weird.

However I'm now experiencing something new with the display: same areas of the working window are not being refreshed. For example, when selecting several cells in Calc, on the top-left where ranges are shown, all the chars get scrambled and you can no longer distinguish what's in there. I'll put a new topic with this. Thanks!

laimaretto gravatar imagelaimaretto ( 2016-05-21 18:25:35 +0200 )edit

Hi! So I've found what's causing the issue: it's the package libreoffice-gtk3. I've I enable it then the reported issue appears. But if I disable it I start experiencing another issue which is a bug that I've reported already to https://bugs.documentfoundation.org/s... Cheers!

laimaretto gravatar imagelaimaretto ( 2016-05-24 15:38:32 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-05-20 20:48:51 +0200

Seen: 648 times

Last updated: May 20 '16