Ask Your Question
0

Backspace key cause font change. How to prevent this?

asked 2016-05-30 20:46:19 +0100

spflanze gravatar image

updated 2016-05-30 20:49:12 +0100

The selected font for entire LibreOffice Writer document is Verdana. In:

Tools => Options => LibreOffice Writer => Basic Fonts (Western)

I have selected Verdana for all fields. Also, Verdana is selected in the Font Name field to the upper left in the tool bars.

Whenever I use the backspace key to delete the most recent character typed the font changes to Liberation Serif, and any new characters are in Liberation Serif until I change the font back to Verdana. I need the font not to change. It is costing me time. Is this due to a LibreOffice setting? If so what is the setting. Or is this a bug?

My LibreOffice version: 5.1.3.2

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2016-06-10 16:12:54 +0100

Júlio Reis gravatar image

You should change the style rule for the default text style.

  1. Menu option: ‘Format > Styles and Formatting’. A pane should appear somewhere.
  2. Right-click ‘Default Style’. From the context menu choose ‘Modify’.
  3. Pick the tab ‘Font’. Pick ‘Verdana’ from the ‘Family’ setting – either start typing it, or select it from the font list.
  4. Push the ‘OK’ button. All text in the default style should now be in Verdana.
edit flag offensive delete link more

Comments

In the Format pull down menu there is not a "Styles and Formatting" menu item. In the Styles pull down menu the "Styles and Formatting" menu item does appear. Once this is selected a pane opens to the left showing all the styles. When I right click the "Default Style" line a dialog box opens with the title "Paragraph Style: Default Style". In this dialog box's Font tab I see that the Verdana font is already selected.

Your procedure does not solve it.

spflanze gravatar imagespflanze ( 2016-06-16 23:24:23 +0100 )edit

The Styles menu is a recent addition. Not everybody is aware of that. I have been toying with direct formatting and pressing Backspace, but I can't make it change the font. It only deletes the character to the left of the cursor. So it is most likely something linked to your system/operating system/custom settings.

floris v gravatar imagefloris v ( 2016-07-21 21:37:15 +0100 )edit
0

answered 2016-07-21 14:55:56 +0100

jws gravatar image

updated 2016-07-21 15:56:12 +0100

LibreOffice 5.1.4.2

I have the same problem, and found this thread, which still seems to be recent and open.

It does not seem to do with styles at all:

  • I have the style set to the font I want (Arial in my case)
  • The style and font show in the toolbar.
  • I start typing in the cell and it's Arial.
  • Then I backspace, and the font changes to Liberation Serif
  • The Liberation Serif font shows in the toolbar and also new text I enter is Liberation Serif
  • The style in the toolbar has not changed - it is still the style I want.
  • Now I select the text in the cell, and in the Format menu I click on Clear Direct Formatting
  • This clears the Liberation Serif, and the font of all the text reverts to the correct font (Arial) defined in the Style.

So it looks to me like the backspace is initiating Direct Formatting over-riding the style. I would have said this is a bug.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-05-30 20:46:19 +0100

Seen: 905 times

Last updated: Jul 21 '16