Ask Your Question
0

Document locked in specific folder

asked 2016-06-02 01:00:36 +0200

Dumbbell gravatar image

I have a bunch of .WPS documents in my Documents folder on a brand new Windows 10 x64 PC copied from an olf XP computer. When I try to open any of them in the latest version of LibreOffice I get an error message

Blockquote Document file '<whatever>.wps' is locked for editing by: Unknown User Open document read-only or open a copy of the document for editing Blockquote

If I copy the document to the desktop it opens fine. I then move it back to Documents and the above error comes back. The Windows account I am using has Admin rights. If I look in properties I do have full control. What's up please ?

edit retag flag offensive close merge delete

Comments

When you went to Properties to check you had Full Control make sure you did it for the "My Documents" folder and not the individual doc or docs. Also did you go the the "Advanced" button and then in the bottom left corner tick "Replace all child object permissions entries with inheritable permission entries from this object." ? Try that and see what happens.

irongron gravatar imageirongron ( 2016-06-02 05:18:13 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2016-06-02 11:58:56 +0200

Dumbbell gravatar image

Very good thoughts irongron, I had not done that. Now I look at the Documents folder and see that Read Only is checked. So I uncheck it and ask that the change be propagated. I than look at the individual docs and see no read only so I think hopeful thoughts.

Alas, same problem. I then look at the documents folder and see it still has the read only attribute set. Then I look on another PC where there is no problem and see the read only flag IS set there. Confusion sets in. The Desktop folder (from where I do not have the problem) is also showing read only.

Perhaps there is a clue in the error message: "Unknown user". Let's try setting full access to 'Everyone'. I did that and saw that it was propagated down to individual documents but still the same error ! I then looked at effective permissions on an individual document for the user and that confirmed full control. Not surprising as that user is also shown as the document owner.

I wonder how Libreoffice determines the locked status of a document. This is only a single user PC so there's never going to be any concurrent editing issue.

edit flag offensive delete link more

Comments

If you do a search for "documents read only in windows 10" you get lots of hit such as "Windows-10 changed all my documents to "Read-Only" - CNET" or "Installed Windows 10 and now all my documents in read-only ..." or "Document folders marked read only after upgrade to Windows 10 ...". It seems to be a very common problem for Windows 10 users. After looking at the dozens of hits regarding this Read Only problem with docs I would be more inclined to think it is a Windows 10 issue and not LO...

irongron gravatar imageirongron ( 2016-06-03 07:18:51 +0200 )edit

Oh one other thing that may be important, when you check the properties of "My Documents" make sure you do it at C:\Users\username\documents and not at My Documents which is kind of a system type alias folder.

irongron gravatar imageirongron ( 2016-06-03 07:23:43 +0200 )edit
0

answered 2016-06-03 07:28:29 +0200

irongron gravatar image

updated 2016-06-03 07:29:23 +0200

Someone who had the same problem as you suggested this and it seemed to work for them, they claimed. Although beats me how as "Sharing" is for networking. but anyway, it might be worth a shot.

"Actually, I had the same thing, and was unable to change anything in the Security tab, either.

Try this instead:

Go to "This PC - Windows (C: - Users" and right-click the one that has the problem.

Click "Properties" and choose the "Sharing" tab.

Click "Share". In the lower box, you should see at least two rows: one is "Everyone" with a permission level of "Read-only", and another one with a permission level of "Owner". Type in the name of the "Owner", and click "ADD". Finally, click "Share" at the bottom of the box.

It'll take a couple of minutes, though not very long, and then a message appears telling you that the items have been shared. Click "done" and your problem should be fixed. "

edit flag offensive delete link more
0

answered 2016-06-02 17:18:12 +0200

peterwt gravatar image

If you look at the properties of any file on a windows PC they will all have in the General tab the Read-only attribute set with a black square. It should also have following this (Only applies to files in folder). This is a confusing indication and does not mean that all files in the folder are Read-only. It is provided as a means of CHANGING the attribute of all files in the folder as a block. If you have some files in that folder that are set as Read-only then you can change them all by clicking on the Read-only attribute in the folder properties so that it is now blank and applying the change. The folder property Read-only will show the black square if you look at it again but all files in that folder will now not be Read-only. If you click on the folder Read-only property so it becomes blank and then click again a tick will appear. If you apply this all files will now be read-only.

If you create a new LO document and save in My Documents can you open it without the locked error?

I have in the past come across a problem with files transferred from another computer. If you look at the properties of one of the problem files in the General tab is there below the attribute setting "Security This file came from another computer and might be blocked to help protect the computer". There is to the right of this an "Unblock" button.

The way LO locks a file is to create in the folder where the file is a file .~lock.filename#. It also creates a lock file in the LO profile in AppData/Roaming/LibreOffice/(LOVersion)/.lock. Make sure with LO closed there are no such files - delete if there are.

edit flag offensive delete link more

Comments

Thanks for all the above. None of the seemingly good suggestions worked for me. I have now moved all documents to a folder on the desktop and that works around the problem satisfactorily. New documents do to the Documents folder and open as expected. Thanks again.

Dumbbell gravatar imageDumbbell ( 2016-06-04 11:17:58 +0200 )edit

Have you tried opening one of these docs from the desktop file and saving it with the name changed into MyDocuments as it should then look like a new file that you say does work.

peterwt gravatar imagepeterwt ( 2016-06-04 12:38:41 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-06-02 01:00:36 +0200

Seen: 406 times

Last updated: Jun 03 '16