Mail merge rounds in writer when it doesn't in calc. Is this a bug?

asked 2016-06-04 00:35:21 +0200

Varrin gravatar image

updated 2016-06-04 00:37:00 +0200

From beginning to end:

Calc spreadsheet Sheet1 has a table (used like a database) with a column formatted Number - General. Some entries have three decimal places.

The same Calc spreadsheet Sheet2 has a table used for mail merging that performs VLOOKUP on Sheet1 to populate data. The relevant column also shows Number - General. The numbers on that sheet are displayed correctly in calc (eg. if it has three decimal places, three decimal places are displayed).

I have a Writer document that mail merges using the Calc spreadsheet Sheet2 as a database. When I Ctrl-P to mail merge, the database brings up the fields, but the numbers that have three decimal places are rounded to two decimal places.

Question: Is this a feature or a bug? It seems like a bug to me. When I insert the field as Format:From Database, shouldn't it inherit the format from the Calc spreadsheet? It doesn't appear to be doing that.

If it's a feature (why?), is there a way to force it to display all three (or more) decimal places but only when they are present? User Format with three decimal places (0.000) gives trailing zeros when the original has none.

Version is 4.4.7.2.

Thanks in advance for any insights!

V-

edit retag flag offensive close merge delete