Ask Your Question
0

Newly installed LibreOffice 5 crashes opening any spreadsheet

asked 2016-06-07 13:42:36 +0200

reedmace gravatar image

updated 2016-06-07 20:52:20 +0200

Win 7 Pro 64 bit; LibreOffice 5.1.3.2 (x64); (MS Office 2013)

Have been using OpenOffice 4.x with a mixture of .ods and .xls spreadsheets for years. Decided to try the switch to LibreOffice a few days ago after discovering OO has been sidelined. Uninstalled OO, installed LO (first the ordinary version, then later x64).

Calc will open a blank spreadsheet, but crashes on every attempt to open an existing .ods or .xls file and attempts to go to documnet recovery but without lising any file (Can't upload image as I "need 3 points"???). Program then returns to opening screen. Repeated attempts to open any existing spreadsheet all cause same crash. Have tried uninstall and reinstall without avail.

Can't find anyone else having this problem, but needless to say, am very close to giving up and just reverting to MS.

Reedmace

Have uninstalled x64 and reinstalled x86 as suggested. Problem persists. Backtrace has been performed and has now finished. Unable to upload text file with results as still don't have enough points??? Backtrace pasted below:

    *******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************

*** WARNING: Unable to verify checksum for C:\Windows\SysWOW64\OpenCL.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Windows\SysWOW64\OpenCL.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Program Files (x86)\LibreOffice 5\program\soffice.bin - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Users\nnn\AppData\Roaming\Dropbox\bin\DropboxExt.34.dll - 

FAULTING_IP: 
+0
18a54408 15000000e0      adc     eax,0E0000000h

EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 0000000018a54408
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000008
   Parameter[1]: 0000000018a54408
Attempt to execute non-executable address 0000000018a54408

CONTEXT:  0000000000000000 -- (.cxr 0x0;r)
eax=18a54408 ebx=18bd6b78 ecx=18aa7de8 edx=0000007f esi=18aa7de8 edi=18bd6b78
eip=18a54408 esp=00eba9e8 ebp=00ebaa64 iopl=0         nv up ei pl nz na po nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010202
18a54408 15000000e0      adc     eax,0E0000000h

FAULTING_THREAD:  0000000000002a64

PROCESS_NAME:  soffice.bin

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

EXCEPTION_PARAMETER1:  0000000000000008

EXCEPTION_PARAMETER2:  0000000018a54408

WRITE_ADDRESS:  0000000018a54408 

FOLLOWUP_IP: 
+0
18a54408 15000000e0      adc     eax,0E0000000h

FAILED_INSTRUCTION_ADDRESS: 
+0
18a54408 15000000e0      adc     eax,0E0000000h

NTGLOBALFLAG:  0

APPLICATION_VERIFIER_FLAGS:  0

APP:  soffice.bin

ANALYSIS_VERSION: 6.3.9600.17336 (debuggers(dbg).150226-1500) amd64fre

IP_ON_HEAP:  0000000018a54408
The fault address in not in any loaded module, please check your build's rebase
log at <releasedir>\bin\build_logs\timebuild\ntrebase.log for module which may
contain the address if it were loaded.

BUGCHECK_STR:  APPLICATION_FAULT_SOFTWARE_NX_FAULT_INVALID_ZEROED_STACK

PRIMARY_PROBLEM_CLASS:  SOFTWARE_NX_FAULT_INVALID

DEFAULT_BUCKET_ID:  SOFTWARE_NX_FAULT_INVALID

ADDITIONAL_DEBUG_TEXT:  Followup set based on attribute [Is_ChosenCrashFollowupThread] from Frame:[0] on thread:[PSEUDO_THREAD]

LAST_CONTROL_TRANSFER:  from 0000000000000000 to 0000000000000000

STACK_TEXT:  
WARNING: Frame IP not in any known module. Following frames may be wrong.
00eba9e4 284f6923 00ebaa5c 18abfbe0 18aa7de8 0x18a54408
00ebaa64 2849bcaf ...
(more)
edit retag flag offensive close merge delete

Comments

That is with both, the x64 64-bit version of LibreOffice and the x86 32-bit version? That would be very odd. Try to deinstall completely and install the 32-bit version. If problem persists we'd be interested in a backtrace, see https://wiki.documentfoundation.org/H...

erAck gravatar imageerAck ( 2016-06-07 14:24:23 +0200 )edit

Just wondering if anyone is following this up?

reedmace gravatar imagereedmace ( 2016-06-08 16:29:57 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2016-06-09 11:01:07 +0200

erAck gravatar image

updated 2016-06-09 11:05:41 +0200

Likely you're a victim of your OpenCL driver. Try to disable OpenCL under Tools - Options - LibreOffice - OpenCL

Failing that, try to disable DropBox or exclude paths LibreOffice writes to, e.g. temporary and backup files, configuration files, ...

edit flag offensive delete link more
0

answered 2016-06-09 11:39:59 +0200

reedmace gravatar image

updated 2016-06-09 20:26:16 +0200

Disabling OpenCL as instructed has solved the problem. Thank you. However, does this mean that LO will now only run on a single core on my i7 machine?

edit flag offensive delete link more

Comments

Most runs on one core anyway. However, with OpenCL some larger amounts of spreadsheet data are calculated on the GPU.

Could you please give detailed information on the OpenCL driver, such as manufacturer and exact version number, so it can be added to the blacklist? Thanks.

erAck gravatar imageerAck ( 2016-06-09 16:02:01 +0200 )edit

Where can I find details of the driver? The OpenCL.dll info (in Windows\SysWOW64) is as follows: Company=Khronos Group, v1.2.11.0, created 15/01/2013

reedmace gravatar imagereedmace ( 2016-06-09 20:24:19 +0200 )edit

http://dev-www.libreoffice.org/opencl...

This should generate a file with all the necessary info to blacklist that device driver combination.

moggi gravatar imagemoggi ( 2016-06-10 14:14:04 +0200 )edit

Check if there is a file called 'opencl_devices.log' in the 'cache' folder in your LibreOffice profile.

Tor Lillqvist gravatar imageTor Lillqvist ( 2016-06-10 14:14:30 +0200 )edit

Moggi - Opencl Info.exe crashes after a few moments creating an empty file called opencl.log

Tor - there is an opengl_devices.log, but no opencl_devices.log

reedmace gravatar imagereedmace ( 2016-06-10 16:28:04 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-06-07 13:42:36 +0200

Seen: 1,831 times

Last updated: Jun 09 '16