Ask Your Question
0

Right Alt key not working

asked 2016-06-07 17:15:02 +0100

Tmaggie84 gravatar image

Version: 5.1.3.2 (x64) (updated on June 6, 2016) Windows 7 - Calc, Writer (haven't really tested other apps)

About 2 LibreOffice updates ago, my Right Alt key stopped working; e.g., ALT+F simply put a text "f" in whatever cell or line the cursor is in. I was hoping a new update would fix this.

Left Alt is working.

I searched and found a problem logged, but it appeared to be Ubuntu related.

Please help, this is driving me nuts. I'm a touch typist...

edit retag flag offensive close merge delete

Comments

What do you expect with ALT+F? In the shortcut keys is no entry. Please provide the bug# of the Ubuntu problem.

horst gravatar imagehorst ( 2016-06-07 22:41:37 +0100 )edit

8 Answers

Sort by » oldest newest most voted
1

answered 2017-01-22 01:04:09 +0100

peterwt gravatar image

updated 2017-01-22 13:48:20 +0100

On modern keyboards the Right Hand Alt key is marked Alt Gr which stands for Alt Graphics. It's function is different to the Left Hand Alt and what it does depends on the Keyboard layout and the operating system.

On my UK keyboard with Windows 8.1 the Alt Gr key with these keys produces -
a > á
e > é
i > í
o > ó
u > ú
4 > €
¬ > ¦

This gives these results on all applications including Notepad, MS Office, LO. The same results are produced by using Control + Left Hand Alt as Alt Gr produces the same Keycode as Control + Left Hand Alt.
See here

edit flag offensive delete link more
0

answered 2017-01-21 22:58:09 +0100

I am bothered by this problem also. The Right-Alt key does not work with any key, not exactly.

Oddly enough Right-Alt works -- if you let go of it first!

  • As expected Left-Alt+T, release opens the Tools menu, for example.
  • Right-Alt, release, T, release will get me to the Tools menu.
  • Right-Alt+T, release just prints a "t" in the document.

The key does not work that way in any other application.

edit flag offensive delete link more

Comments

Thank you for this at least partial solution. This has been driving me crazy, too. Both left and right Alt keys have always worked with the menu items (F for file, etc.) in American versions of Windows. If the right Alt key can't be made to work the way it does in every other Windows applications, I may have to look for an alternative.

Catemaco gravatar imageCatemaco ( 2017-09-11 19:13:50 +0100 )edit
0

answered 2017-07-12 03:57:13 +0100

LibreTraining gravatar image

updated 2017-07-12 03:58:42 +0100

This is a LibreOffice bug.

LibreOffice does not operate properly on the US keyboard layout on Windows.
It improperly treats the right ALT key as if it is on an International layout keyboard.
So none of your ALT+ or Ctrl+ALT+ etc. key combinations work properly when using the right ALT key.

Tested on Word 2013 and Word 2016 on Windows 7 with a US keyboard setting - all works correctly.
Any combination of left ALT or right ALT with Ctrl or Shift works as expected.

I have added a number of keyboard shortcuts to LO that are obviously missing (e.g. changing the view).
I can only use the left ALT key which makes for some odd habits to hit the right keys.

This is a VERY ANNOYING LibreOffice bug.
It only affects the entire United States ... so not a priority.

edit flag offensive delete link more
0

answered 2017-07-09 15:48:54 +0100

petermau gravatar image

This is actually a Keyboard / Operating system setup question. The Alt-Gr + key is read by the keyboard/operating system and passed to LibreOffice, it is not decided by LibreOffice. The topic is discussed in the topic https://ask.libreoffice.org/en/questi... The note below work on my Linux Mint system for all the software and all my versions of LibO (EN-GB) 4.0, 5.3, 5.4. The key is actually understanding the purpose of Alt-Gr. It applies to the versions of Windows that have a Alt-Gr (Right Alt key). Alt-Gr or Right-Alt is not the same as Alt but on the right hand side.

Briefly, the keyboard has four levels for entering characters.

My default keyboard is English UK extended Winkeys

Level 1 Lowercase Letter (a c d e etc.. for example)

Level 2 Uppercase Shift + letter (A C D E)

Level 3 Alt-Gr (right Alt) + letter (depending on keyboard for me á ç ð é ) Level 4 Alt-Gr Shift + letter (Á Ç Ð É)

Using the same keyboard but changing the setting to American International gives

                    a c d e    A C D E    á © ð é    Á ¢ Ð É

Swiss German a b d e A B D E æ ¢ ð € Æ ’ Ð E

Irish a c d e A C D E á ̧ð é   Á ¸ Ð É

I hope this provides a little information. In America, a Windows system is often set to ignore the level 3 and 4 so they struggle to put in accented characters and Alt-Gr is unpredictable. always check that the keyboard is set to International.

edit flag offensive delete link more
0

answered 2017-07-08 17:36:01 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

This is the same problem of as the right Alt key in Putty, so the solution is the same:

Make a reg file, say, RightAlt.reg

Copy & Paste the following:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout] "Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,38,00,38,e0,00,00,00,00

Save and double-click to import the registry.

Re-start Windows, then the right alt key is fine.

For explanation, check

https://www.emacswiki.org/emacs/PuTTY...

edit flag offensive delete link more
0

answered 2016-06-08 22:42:14 +0100

horst gravatar image

I tried LO 3.5 up to 5.1 and the right ALT (=ALTGr) does not work at all. I updated to Win10 recently. BUT the left ALT key works the way you want it.

edit flag offensive delete link more

Comments

I do miss the Right Alt functionality - it made my life so much easier. /sigh

I guess I'm just "special" like that. I looked for a way to set up the shortcut to attach to the key stroke, but I couldn't figure it out - didn't seem to be a viable option in any of the customization menus. Thanks for checking your system for me.

Tmaggie84 gravatar imageTmaggie84 ( 2016-06-09 21:21:27 +0100 )edit
0

answered 2016-06-08 17:23:19 +0100

Tmaggie84 gravatar image

updated 2016-06-08 17:50:14 +0100

(Right) Alt+F worked consistently...up until it didn't. The posting I found about this issue can be found here: http://ubuntuforums.org/showthread.ph...

It seems to be the same problem, and the user was directed to a site. When I tried to reach the site, I timed out.

I have found that F10 will activate the "File" option on the menu - but doesn't open the drop down menu attached, which is what I miss having available. I used to be able to (r)ALT+F and then use a keyboard option from the menu to execute my next command. A simple F10 moves the focus to the "File" option but does not activate the drop down menu, which still necessitates more keystrokes. I can't find the option to attach to my desired short cut keys.

edit flag offensive delete link more
0

answered 2016-09-10 22:09:51 +0100

I'm experiencing the same issue. I figured there would be documentation about the problem and certain that the change must have been done for some specific reason. But, perhaps we are the only two people in the world who use the right Alt key. I use keyboard shortcuts all day long and being limited to the left alt key is quite frustrating.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-06-07 17:15:02 +0100

Seen: 3,329 times

Last updated: Jul 12 '17