Ask Your Question
0

The spell-checker (within writer) does not work for me when I use a second language, always reporting spell-check complete even on deliberately introduced spelling errors.

asked 2016-06-17 10:03:16 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have installed libre office writer 4.4.7.2 on Mageia 5. Default language is English but I have installed the Ukrainian spellcheck dictionary and thersaurus 2.0 extension package with no indication of errors. Format→character→language shows that Ukrainian is blue-ticked. Ukrainian is a variant of Cyrillic. Keyboard can be toggled between Ukrainian and English. Florence is used as an on-screen keyboard for Ukrainian (also works correctly with English). Any help on steps to solve this issue would be appreciated as my current understanding of LO internals is very limited.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2016-06-18 08:23:15 +0100

ajlittoz gravatar image

updated 2016-06-21 08:02:04 +0100

Spellchecking works with language hints: the appropriate dictionary, thesaurus and rules are selected from an attribute of the paragraph or word. This is especially important in multi-lingual documents.

Default language is defined by Tools->Options..., Language settings. Per definition, it applies to any text which is not flagged otherwise.

When you type a full paragraph in a non-default language, you must tell it to LO. As an example, let's say your paragraph has style Text Body (I suppose here that you are familiar with the concept of styles and are using them -- otherwise, you are strongly encouraged to read the relevant chapter in the user manual downloadable from the LO site). You clone this style and change the language attribute.

  • Open the style directory Format->Styles and Formatting... or F11
  • Right click on Text Body and choose New...
  • In the Organizer tab, give a name, like Text Body (Ukrainian)
  • In the Font tab, select Ukrainian language from the drop-down menu
  • Click OK

Now you have Text Body to style default paragraphs and Text Body (Ukrainian) for Ukrainian paragraphs.

If you need to type a single foreign word in a paragraph (e.g. a Ukrainian word in an English paragraph or an English word in a Ukrainian paragraph), paragraph styles won't do the job. You must create specific character styles.

The procedure is similar to the previous one.

  • Open the style directory Format->Styles and Formatting... or F11
  • Click on the second icon from the left in the toolbar (Character styles), the one with a small "a"
  • Right click in a free area and choose New... (or alternatively clone a style with a right-click on a name)
  • In the Organizer tab, give a name, like Ukrainian
  • In the Font tab, select Ukrainian language from the drop-down menu
  • Click OK

Do the same with English to allow insertion of English in Ukrainian paragraphs.

After inserting the foreign text, select it with the mouse and give it the required character style. Then this text will be spell-checked separately from the paragraph where it is written.

If you think this correctly answers your question, please tick it for community benefit.

edit flag offensive delete link more

Comments

I appreciate the clear explanation. I had assumed that switching the keyboard character set somehow sets the language setting and of course, there is no reason why it should as these are two separate issues.. Thanks again.

vzawalin gravatar imagevzawalin ( 2016-06-20 09:46:29 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-06-17 10:03:16 +0100

Seen: 632 times

Last updated: Jun 21 '16