Ask Your Question
0

Changed font colour reverts back to automatic

asked 2016-06-21 16:46:42 +0100

JaakkoK gravatar image

updated 2016-06-21 16:47:19 +0100

I am using LO 5.0.6.3 in 64 bit Windows 7 Professional.

My problem is this. I have inherited a document from a previous author and am editing it. While I am inserting text, I would like to have the bits i type to appear in a different colour from the (automatic) black colour of the original font. I don't want to use track/show changes and keep any deleted bits visible. I simply would like to type into the document, here and there, in a different colour (say, green or magenta) from the original.

When I try to do this, I run into a problem. Initially it appears I can change my font colour from the toolbar just fine. I can paint sections of the text and have them change colour as I like, and I when I choose a font colour, at first my typing appears in that colour. However, when I have finished that bit and move on to the next section I want to edit, the colour reverts back to the automatic black of the document. That is, the colour I selected for my text does not keep, and to constantly write in magenta or green I would have to choose the colour from the toolbar again and again. This is quite bothersome.

The document is a originally Word document. I have tried saving it in .odt format, but the problem persists. I have also experimented with a LO document created from scratch, and it behaves the same way. You can change the colour of the font you type for that one bit, but as soon as you jump to the next place (next sentence, next paragraph, whatever) the colour you typing in reverts back to the colour of the original font.

I suspect it might be a case of some style attribute taking over, although what I see in the style window is "Default Style".

But surely there must be some way I can simply insert text into the document in green, magenta etc., without constantly having to change the font colour for each separate instance?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-06-22 08:35:29 +0100

ajlittoz gravatar image

When you set the cursor at any location for typing, "initial" text attributes are defined by the local properties in order: paragraph style, character style, manual formatting (the latter overrriding the former). All three layers are kept in the document as "directives" to typeset the text.

Note that the character style layer does not exist in M$ Word.

What you do when you select an attribute from the toolbar is to replace the manual formatting layer. The manual formatting layer can be considered an extra "anonymous" layer.

When you jump to another location, the three layers are different, which explains why you must redefine your text color.

To alleviate your burden, I'd suggest you define a character style:

  • Open the style directory Format->Styles and Formatting... or F11
  • Click on the second icon from the left in the toolbar (Character styles), the one with a small "a"
  • Right click in a free area and choose New... (or alternatively clone a style with a right-click on a name)
  • In the Organizer tab, give a name, like MyEdit
  • In the Font Effects tab, set whatever attributes you like
  • Click OK

Now, after setting your cursor to the insertion position, double-click on MyEdit in the Styles and Formatting list to set the properties. You can also set them afterwards by selecting a run of characters, then double-clicking on the style name.

To remove your custom attributes, select a sequence and double-click on Default Style. However, since your original document come from M$ Word (there is no character style layer), you may need to first remove the manual formatting with Format->Clear Direct Formatting or Ctrl+M.

Defining a custom character style gives you versatility as you can edit your style and your changes will automatically be reflected in all styles locations without the burden of tracking them manually.

Once you're satisfied with the state of your document, you can either set your MyEdit style to some "neutral" state (and keep the MyEdit markup) or used the advanced search and replace function to remove the MyEdit markup, but that is another question.

If you think this correctly answers your question, please tick it for community benefit.

edit flag offensive delete link more

Comments

Thanks, ajlittoz. I did as you instructed and created "MyEdit". The way it works now is that each time I move the cursor, I still have to go to Styles and Formatting and double click MyEdit, as the characters revert back to the original style of the document at each new location. But it's true it's so much better than having to go to the toolbar to choose the colour. Is that the way you intended it? Either way, thank you so much for making my life that bit easier.

JaakkoK gravatar imageJaakkoK ( 2016-06-22 11:09:13 +0100 )edit

Yes, that was the intent.

You must understand there is no way to set default attributes when editing a document. The MyEdit trick is the closest I could find.

If you're so pleased with my answer, you can "up" it so that it will be easier to locate for others.

ajlittoz gravatar imageajlittoz ( 2016-06-22 17:00:10 +0100 )edit

Thanks again, I can certainly manage with that. Clicking the up arrow I get a message saying 5 points required to upvote, so no can do, I'm afraid.

JaakkoK gravatar imageJaakkoK ( 2016-06-22 19:07:55 +0100 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2016-06-21 16:46:42 +0100

Seen: 778 times

Last updated: Jun 22 '16