Ask Your Question
0

Incorrect display months [calc] ??

asked 2016-07-02 21:27:43 +0200

LibreGuy gravatar image

Hi guys,

I'm using a spreadsheet in which I created a custom style to show the day, month and time.

The style I used is: DD-MM UU:MM:SS

When I inserted the current time in a cell like this: 29-05-2016 22:42:40

In the spreadsheet it showed like this: 29-05 22:42:40

So, in other words, this DD-MM UU:MM:SS resulted in this 29-05 22:42:40

However, today I noticed something very strange. I haven't changed anything, but all of a sudden the months are not being displayed correctly anymore.

Instead of this 29-05 22:42:40 I am now seeing this 29-42 22:42:40

So the mont number is totally incorrect. How could this be all of a sudden? Any ideas?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2016-08-08 15:49:04 +0200

LibreGuy gravatar image

This problem seems to be solved now in updated version (5.2.0.4).

Thanks to the developer who fixed it!!!

edit flag offensive delete link more
0

answered 2016-07-02 23:00:56 +0200

m.a.riosv gravatar image

updated 2016-07-02 23:01:26 +0200

There is a bug report in relation https://bugs.documentfoundation.org/s..., solved for 5.1.4 and posterior versions (2016-05-25)

edit flag offensive delete link more

Comments

Thanks! You are pointing me in the right direction. That 42 in 29-42 22:42:40 is indeed the amount of minutes! :-) However, it was and should be the number of the month. How can I fix that? I am using LO version 5.1.4.2 Fresh. What should I do to solve this problem?

LibreGuy gravatar imageLibreGuy ( 2016-07-02 23:23:27 +0200 )edit

Please could you attach a minimal sample file, I can't reproduce the issue?

m.a.riosv gravatar imagem.a.riosv ( 2016-07-03 11:18:24 +0200 )edit

I don't know how to attach a file but I will explain how to reproduce. It's really simple:

  • create a new/empty spreadsheet
  • in cell A1 right-click mouse and choose Format Cells...
  • go to the tab Numbers
  • on the bottom it says Format code
  • in the textbox enter "DD-MM UU:MM:SS" (without quotes)
  • press the OK button
  • now insert the current time by pressing Ctrl + Shift + :

It should show day-month time but is shows day-minutes time. Can you reproduce?

LibreGuy gravatar imageLibreGuy ( 2016-07-03 18:05:19 +0200 )edit

I can reproduce now, on first I couldn't see because in Spanish hours use H, and if you delete the hours seems to works fine, so with U for hours works fine for me showing U instead the hours.

m.a.riosv gravatar imagem.a.riosv ( 2016-07-03 23:41:56 +0200 )edit
m.a.riosv gravatar imagem.a.riosv ( 2016-07-03 23:42:14 +0200 )edit

"I can reproduce now" Alright, just to be sure ... you also see minutes instead of the number of the month, correct? I don't know how to report a bug and I don't have a login for the Bugzilla. Is it something you are willing to do for me perhaps? If you have time?

LibreGuy gravatar imageLibreGuy ( 2016-07-03 23:49:53 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-07-02 21:27:43 +0200

Seen: 78 times

Last updated: Aug 08 '16