Paste-Special works non-intuitively in pasting formatted text.

asked 2016-07-04 00:35:40 +0200

gearhead gravatar image

updated 2016-07-10 23:51:28 +0200

The Paste-Special command (Edit > Paste-Special, or Ctrl-Shft-V) should let the user paste Formatted text [RTF] that retains the font, size, and color of the original text. (This is very useful e.g. when you need to insert frequent computer-style commands in typewriter font.) Instead, the formatted Paste loses all original information. It acts no different from the Unformatted option.

The workaround in Impress is apparently to specify EditEngineFormat. But this menu option is never explained, or even mentioned, in Impress Guide 4.0. It is not even present in Writer. The same capability worked in PowerPt, so there seems to be no compelling reason that LibreOffice should not support it.

edit retag flag offensive close merge delete

Comments

+1 for this feature request -- thanks for considering it! :-)

Clarification: When I paste-special some formatted text from another .odt document, I get 5 options of how to paste, including RTF -- great! The feature I'm missing (that OpenOffice.org had) is to have the RTF option when I copy-paste from my Mac Terminal, which has monospaced font and various custom colors.

votermedia gravatar imagevotermedia ( 2017-03-22 16:56:09 +0200 )edit