Ask Your Question
0

How to delete altsearch.oxt saved batches?

asked 2016-07-04 00:50:04 +0200

dkistner1111 gravatar image

After much mucking around, I figured out that AltSearch is exactly what I need for my book production workflow. But while I was figuring it out, I saved a bunch of searches that I now want to delete so I've only got "the good stuff."

Removing the altsearch.oxt extension via the Extension Manager and reinstalling it doesn't do it. Uninstalling and reinstalling LibreOffice, then reinstalling altsearch.oxt doesn't do it. It's like I've created zombies that just won't die!

This seems like such a basic need...maybe I'm missing something in the extension itself? But after hours at it, I have yet to figure it out. Can somebody please help me? Is this a file somewhere that just needs to be deleted after the extension is removed before doing a clean install?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2016-07-04 15:45:48 +0200

dkistner1111 gravatar image

Paul, you are so kind to be helpful to me. I'd been all through the help file and wasn't seeing anything that helped. What I finally managed to do was to drag LibreOffice.app to AppCleaner and delete everything, then reboot, reinstall everything yet again.

I'm still getting the error that the text editor is not found, no matter how precise the path I enter in the error box, but at least I've got what I originally needed, which was all those custom-saved batches gone. But it didn't happen until I used AppCleaner to uninstall LibreOffice.

I've got to get more karma to uptick you! This is the first time I think I've ever come to this forum to ask a question.

edit flag offensive delete link more

Comments

My apologies, dk. The comment I left earlier was erroneous. I had confused editing the Help file (I found the fonts and colors hard to read) with editing the settings file. I've corrected that comment.

I'm sorry you went to all this trouble, but at least it's working. Here's what I just tried:

  1. I went to the Batch tab and clicked Edit. Yesterday this worked; today it told me the file did not exist. The only thing different is that I created, and then deleted, a batch file. (continued)
paul1149 gravatar imagepaul1149 ( 2016-07-04 16:49:18 +0200 )edit

(cont) The error msg gave me the file path. So I went there in my file explorer and successfully edited the file manually. If you do it this way you needn't worry about the path. in linux, the path was /home/<user>/.config/libreoffice/4/user/config/. In Windows, it will be under the <user>\appdata\roaming\LO hierarchy. Not sure about Mac. In the future, you can surgically remove the file rather than wipe the entire profile, which is what I suspect appcleaner does. It also pays to back it up. BW

paul1149 gravatar imagepaul1149 ( 2016-07-04 16:58:58 +0200 )edit
0

answered 2016-07-04 02:24:06 +0200

paul1149 gravatar image

From the extension's Help file:

All batch parameters are saved to the text file AltSearchScript.txt into the user's directory …/OpenOffice.org2/user/config/, and you can open and edit it using the [ Edit ] button in the Batch manager dialog. For editing the text, the program notepad is used by default, but you can set it to use any other text editor by editing the file AltSearchEditor.ini in the same directory. After manual changing and saving the file using the batch manager you can then refresh the list of batch names using the [ Refresh ] button. The syntax used in the file AltSearchScript.txt is described at the beginning of the same file, using UTF-8 encoding (from v1.1.1).

edit flag offensive delete link more

Comments

This may be the problem. No matter how I specify a path to my TextEdit on my El Capitan Mac, AltSearch doesn't read it. So I don't see any kind of Batch manager dialog. When I press the Edit button, I can edit the script, but I cannot delete it. Is this a bug with the extension? I know it wasn't working for a while and then started working again with 5.1.4, but maybe this is something else that's not working now?

dkistner1111 gravatar imagedkistner1111 ( 2016-07-04 02:37:08 +0200 )edit
  1. Make sure you have the latest version of the extension - 1.4.1.
  2. Click on the extension's script Edit button. That should open the file directly. If it doesn't, it should give you a dialog box with the exact file path. You can then go to that file in your file explorer and open it manually.

If this helps you pls uptick so others will find it.

paul1149 gravatar imagepaul1149 ( 2016-07-04 03:43:01 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-07-04 00:50:04 +0200

Seen: 65 times

Last updated: Jul 04 '16