How change headless codepage?

asked 2016-07-04 13:50:22 +0200

gremlin_tomsk gravatar image

Hi everyone. I've been using LibreOffice headless for Liferay Portal(using soffice -headless -accept="socket,host=127.0.0.1,port=8100;urp;" -nofirststartwizard) for converting documents(doc,docx,xls and etc.) to html. From LibreOffice >4.4 to 5.1 it works fine. I edited LibreOffice 5\share\registry\main.xcd string from <prop oor:name="Encoding" oor:type="xs:int"> to <prop oor:name="Encoding" oor:type="xs:int"><value>76</value></prop> and utf-8 works fine. But in version 5.1.4.2 it does not work. Files after libreoffice becoming with cp1251(Russian windows default codepage) and looks like this https://www.zcarot.com/files/cp1251-u.... Is this bug? How can i change libreoffice use utf-8 permanently?</prop>

edit retag flag offensive close merge delete