Ask Your Question
0

Form suddenly not displaying database data?

asked 2016-07-07 21:58:42 +0100

IceColdRum gravatar image

I'm fairly new to Base but I've managed to put together a reasonably simple database and form to display and enter new entries but suddenly the form is no longer showing any information from the database or any of the information from the drop down combi boxes...

edit retag flag offensive close merge delete

Comments

First, in this forum please respond with a comment or edit your original question with the additional information.

There seems to be a problem with your list boxes (not dropdown menus). You should not be generating lists based upon information in the same table you are trying to update. The more of these you have and the more records in the table the longer the processing. A list box typically has fixed items or is based upon data from a secondary table.

Ratslinger gravatar imageRatslinger ( 2016-07-08 21:20:39 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2016-07-08 20:09:55 +0100

IceColdRum gravatar image

Thanks for taking the time to reply, it literally happened while I was flittering between editing the form and testing to see how it was working.

It started working again after I added a Table control but it now takes ages to actually load the table data... I will click to open the form and it will load and then it hangs for about a minute while the data loads.

I'm using Version: 5.1.4.2 (x64) on Windows 10 64bit

most of the drop down menus are populated from data already in the main table but a few are sourced from other tables and then the data is inserted into the main table once selected, if that makes sense?

edit flag offensive delete link more
0

answered 2016-07-08 01:43:24 +0100

Ratslinger gravatar image

As long as the data is still in the tables, the probable answer is that something changed in the design. Go back and insure the form/subform(s) are pointing to the correct table(s). Also check the controls that they are pointing to the right fields within the table. If using subforms, make sure your link to the master is correct.

Your question is clear but you don't provide much information for resolution. What is your LO version; what OS; how is your form constructed - fields or table; where does the dropdown data originate - table or list. What happened between the time it worked and stopped working - one minute, hour, day?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-07-07 21:58:42 +0100

Seen: 387 times

Last updated: Jul 08 '16