Ask Your Question
0

LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice [closed]

asked 2016-07-09 18:43:57 +0200

TheDatabaseGuy gravatar image

It appears that macOS 10.12 Sierra is going to support Java 6.

However, when clicking on the TABLES option, “LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice.” appears.

When checking LibreOffice > Preferences > LibreOffice > Advanced, “Use a Java Runtime Environment” is ticked but no Runtime environments are listed – even after installing Java 8 OR Java 6.

Clicking on ‘add’ doesn’t seem to help as it doesn’t tell you where to add a Java Runtime Environment from. Guessing it’s /Library/Java/JavaVirtualMachines doesn’t help as only the 1.6.0.jdk folder is present and selecting it only results in “The folder you selected does not contain a Java runtime environment. Please select a different folder.”

Thoughts?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by TheDatabaseGuy
close date 2016-07-09 20:10:12.033251

1 Answer

Sort by » oldest newest most voted
0

answered 2016-07-09 19:02:52 +0200

Ratslinger gravatar image

Please see this post: click here.

edit flag offensive delete link more

Comments

Great! Thanks. I downloaded the Java SE Development Kit 8 and it all worked fine. I really appreciate your assistance.

TheDatabaseGuy gravatar imageTheDatabaseGuy ( 2016-07-09 19:58:53 +0200 )edit

This helped me on the Mac, thank you.

paulfecht gravatar imagepaulfecht ( 2017-02-24 00:55:36 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2016-07-09 18:43:57 +0200

Seen: 8,233 times

Last updated: Jul 09 '16