Ask Your Question
0

XLS file won't open

asked 2012-10-31 04:52:33 +0100

Sonolin gravatar image

updated 2015-08-29 10:02:21 +0100

Alex Kemp gravatar image

Hi, I'm trying to open an XLS file, and when I open it it comes up with a dialog saying "Text Import" like I was opening a CSV file. But, this is a XLS file that one of my clients saved.

I don't really understand why its acting this way, and the data is coming up as corrupt in the spreadsheet. This file does open in google docs and in microsoft office (confirmed).

Unfortunately, there's no way I can get you this file, as it contains secure user/pass info that I can't release to the public. But any help on the issue would be very welcome, as I really don't want to shell out the cash for Microsoft Office! (Even if your help, is how I can "hack" the code of this thing to work. I'm a programmer but just don't have the time to go in and debug this problem without guidance.)

Thanks in advance

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2012-10-31 07:58:59 +0100

Timon gravatar image

Here are several bug repots with the same problem https://bugs.freedesktop.org/show_bug.cgi?id=54082 and https://bugs.freedesktop.org/show_bug.cgi?id=53883 They are not fixed till now and have status NEEDINFO. Describe you problem there. May be it could help to fix problem.

edit flag offensive delete link more

Comments

fdo#54082, fdo#53883
Status: RESOLVED WORKSFORME

manj_k gravatar imagemanj_k ( 2014-01-30 22:18:50 +0100 )edit
0

answered 2012-11-07 23:12:14 +0100

This occurs because the Libre Office 3.6 installation/upgrade program does not properly associate XLS files with Libre Office software. In this case, Windows defaults the association to a Microsoft utility that converts XLS files to an XML format. That's what you're seeing on the screen.

It's pretty easy to correct this problem:

  1. Start up My Computer.
  2. Click on Tools.
  3. Click on Folder Options.
  4. Click the File Types tab.
  5. Wait while the registered file types list populates.
  6. Scroll down to XLS.
  7. Click Change.
  8. Look for Libre Office Calc. It should be listed under Recommended Programs. If not then it may be under Other Programs. If not then click Browse and look for scalc.exe in C:\Program Files\Libre Office 3.6\program.
  9. Click on Libre Office Calc.
  10. Make sure "Always use the selected program to open this kind of file" is checked.
  11. Click OK.
  12. Click Close.
  13. Close My Computer.
edit flag offensive delete link more
0

answered 2015-01-16 15:23:07 +0100

Magefyre gravatar image

updated 2015-01-16 15:24:14 +0100

In my case it turned out that the file I received (.xls) had a blank line at the beginning before the < ? xml version='1.0'?> line. Removing the blank line with a text editor (Notepad++) and resaving allowed me to open the document with Calc.

Hope this helps!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-10-31 04:52:33 +0100

Seen: 14,069 times

Last updated: Jan 16 '15