Ask Your Question
0

language: none vs. autocorrect and spellcheck

asked 2016-07-21 06:55:10 +0100

GordonB gravatar image

I'm trying to find a way of SELECTIVELY protecting content, usually in tables, from getting messed up by auto-correct. Even if you enter it correctly, you can do a lot of damage to the document editing near the entries in question. It does pretty well with actual English paragraphs, but there a number of things that I put in tables that get the case messed up, and they certainly don't spellcheck well: MAC addresses. Passwords. Stock ticker symbols. Fractions (e.g. 1/4" as the size of a screw in inches). License plate numbers. Airport abbreviations. Radio call signs. Part numbers (which occasionally are case-sensitive and flipping the case might change an order from copier paper to a garbage truck.

I'm currently using LO 5.0.6.3 on FreeBSD 10.

I thought I had found a way to do this, but it turns out it doesn't work. Someone told me that if the paragraph style had Language: None, then there were clearly NO dictionaries for a nonexistent language, and therefore no spelling errors. A nonexistent language also does not have capitalization rules, nor sentences, sO lEaVe iT aLoNe.

So, I'd like to propose a new language called "autO correcT handS ofF". Auto-correct and spelling checkers are supposed to not auto-correct and not complain about the spelling of anything in such a paragraph. If you don't like the name, fine, propose a better one, but "None" seems to be already taken, and changing it is probably a no-no because it breaks existing documents. What is language: None for anyway, and why does it appear as a choice when you right-click Modify on the Styles and Formatting Window but not when you right-click Edit Paragraph Style when the cursor is in the document? No paragraph style should default to language: "autO correcT handS ofF", but I might end up applying it to at least some of the Table Contents paragraphs.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-07-21 08:11:52 +0100

ajlittoz gravatar image

updated 2016-07-21 08:13:57 +0100

That's exactly what None language is for. It is one of the many attributes of styles.

You can be very specific if you set it in a character styles. Language None in paragraph styles is very rough: everything or nothing is checked. Having only some "words" (read: sequence of characters) marked as language None allows you to still spellcheck the paragraph with the exception of the marked words.

When your special "words" need also to be highlighted, other attributes such as font or decoration (underline, ...) can also be set so that these words are readily identified in the text.

edit flag offensive delete link more

Comments

Protecting whole table cells from auto-correct is fine. They usually only have one word anyway. But it doesn't work! Try this: create a new writer document. Insert a 5x5 table. Press F11 and find the "Table Contents" style. Right-click modify and set the language to "None". Click OK. Now click in a cell of the table, type "caT", then tab to move to the next cell. Auto-correct changes it to "CaT". Right-click "Edit Paragraph Style" and verify that this cell has language None.

GordonB gravatar imageGordonB ( 2016-07-25 09:42:55 +0100 )edit

That's not spellcheck, this is one of many AutoCorrect options. To set or unset them go to Tools->AutoCorrect options..., tab Options. In this case, uncheck Capitalize first letter of every sentence.

See if the checked options fit your needs unless they will play unwanted tricks on your back, like what you describe.

Check this comment if you find it useful.

ajlittoz gravatar imageajlittoz ( 2016-07-26 08:14:43 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-07-21 06:55:10 +0100

Seen: 53 times

Last updated: Jul 21 '16