Ask Your Question
0

LibreOffice 5.1.4. cannot find firebird sdbc connection

asked 2016-07-30 10:09:17 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Trying to connect LibreOffice Base natively to database Firebird through an sdbc connection. Although I installed the Rirebird SDBC driver for LibreOffice (libreoffice-sdbc-firebird), I could not find a way.

Configuration: OS: Linux Mint 18. / LibreOffice 5.1.4.2 (Build ID: 1:5.1.4-0ubuntu1). / Firebird 3.0. / Installed libreoffice-sdbc-firebird version (1:)5.1.4(-0ubuntu1).

How I tried to connect: Start LibreOffice Base | Opens on page Database Wizard | 1. Select Database | Check: Connect to an Existing Database, Dropdown: No entry for Firebird. The SDBC driver also does not show up in LibreOffice | Menu | Tools | Options | LibreOffice Base | Connections in the Window "Drivers known in LibreOffice".

Is there another way (workaround?) to connect to an external (meaning: not embedded in a Base file) Firebird database natively?

(I did connect via JDBC and it works, but it was tedious to set up and I would like to find a faster way.)

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2020-02-20 11:04:12 +0200

xenon1 gravatar image

updated 2020-02-20 11:05:15 +0200

I found a native sdbc connection in LibreOffice 6:

a) To implement: On the page Database Wizard of LibreOffice Base go to "Connect to an existing database" and choose "Firebird File". If you cannot find this option, please read the next paragraph.

b) Prerequite: In Linux you need the library "libreoffice-sdbc-firebird" (Firebird SDBC driver for LibreOffice). I do not remember if this came installed by default or I had to get it independently. I do not know what you need in Windows and if it is installed automatically.

Evaluation: Plus - Much handier than the previous Java-Connection! Minus (at least for a German) - As far as I could see, it cannot translate the German Umlauts, which are ASCII in the database, into the needed UTF-8 characters of my computer user interface. My guess: This problem may not occur if you configured the database character set to be UTF-8.

edit flag offensive delete link more
0

answered 2016-07-31 22:50:09 +0200

m.a.riosv gravatar image

To activate Firebird drivers is needed to activate experimental features:

Menu/Tools/Options/LibreOffice/Advance - Optional (Unstable) Options - Enable experimental features.

but they are on development currently, Bug 51780 - default to Firebird not HSQLDB in Base.

On the firebird web page there are free drivers to connect Firebird connectivity

edit flag offensive delete link more

Comments

Thank you, m.a.riosv.! But I do and did have experimental features checked when I tried the above sdbc connection. This alone does not change the inability to connect natively to firebird.

xenon1 gravatar imagexenon1 ( 2016-07-31 23:10:40 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-07-30 10:09:17 +0200

Seen: 1,204 times

Last updated: Feb 20