Ask Your Question
0

Base: Uncheck Password required has no effect. Is there a workaround?

asked 2016-07-31 23:24:20 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Setting up database connections in Base using window "Database properties - Connection settings" (I did it to connect to firebird using a jdbc connection) but another user had the same problem with a postgre database (and I do not know which kind of connection):

Unchecking the box "Password required" has no effect: Base still asks you for a password when logging in to your database (just hit enter, if you database does not require a passphrase), and the next time you open the window "Database properties - Connection settings" "Password required" is checked again.

Is there a workaround?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-07-31 23:27:13 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Workaround: Know that the *.odb-file is really a *.zip-Archive that contains all the settings. Open and edit it:

  1. Rightclick on *.odb - file
  2. Open With File-Roller (German: Archivverwaltung) or any application that opens *.zip files; you should see a datastructure now with folder "Configurations2, folder "forms"... until file "settings.xml". In the middle you see file "content.xml".
  3. Open file "content.xml" with any simple text editor (in my case: xed).
  4. Search for db:is-password-required.
  5. You'll find: db:is-password-required="true".
  6. Change this to db:is-password-required="false".
  7. Save and close file "content.xml".
  8. Close file-roller or whatever you unpacked the *odb-file.

That's it. Now you can open your database without entering a password and, if you want to check, the field "Password required" in the configuration window Connection settings (Get there by: Menu | Edit | Database | Properties) is unchecked. But beware: if you check "Password required" it does change the settings, and you may have to go through the above steps again.

This answer is for a Linux system. But, according to another user the problem and the solution is the same for a Windows computer.

(This is already filed as bug 97416, so it does not have to be filed again.)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-07-31 23:24:20 +0200

Seen: 165 times

Last updated: Aug 01 '16