Ask Your Question
1

large Writer file => high CPU, LO sluggish

asked 2016-08-01 21:44:55 +0100

paul1149 gravatar image

I have a sizable .odt file, 782KB, which consists only of plain text, with footnotes and a ToC. The file loads fine, but whenever I do any simple editing, and periodically even when I haven't done anything, LO will drive the CPU up to 50% or more. The machine is a fairly adequate C2D 2.6ghz, with 4GB RAM, running a fresh install of up-to-date Linux x64, and it otherwise runs great.

This happens often with larger files, and also did on my previous Linux install, and with previous LO versions. I'm currently on 5.2.0.3 (RC3). This has happened across several new user profiles.

Is there anything I can do to alleviate this?

Thanks.

edit retag flag offensive close merge delete

Comments

1

It's happened again now. A new file, no footnotes or indexes, just plain text.

It seems a common denominator is that these files tend to be old books copied from Google Play via PDF. I have tried passing them through a text editor (Geany) first, in order to clean them up (as in delete unwanted paragraph divisions). And I always Paste Unformatted into LO But so much as adding a new line can trigger many minutes of 50% CPU, to the point where using LO on the file is not workable at all.

paul1149 gravatar imagepaul1149 ( 2016-08-08 01:20:46 +0100 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2016-08-02 19:48:28 +0100

Marqeaux gravatar image

I encounter the same problem with LibreOffice 5.1.5. Not only in Writer, but also on Calc and Draw. The memory solution doesn't solve the problem. I guess there's something under the hood that has been changed since version 5.1.4, because until the update from 5.1.4 to 5.1.5 I didn't have these problems.

Paul1149 talks about version 5.2.0.3, and I got this problem on 5.1.5.2. I think this problem is related to each other...

edit flag offensive delete link more

Comments

1

My problem predates the entire 5 series, and this particular file goes back probably to 5.1.4.x. I'm up to 5.2.0.4 and it's still there.

paul1149 gravatar imagepaul1149 ( 2016-08-02 20:38:47 +0100 )edit

My problem predates the entire 5 series, and this particular file goes back probably to 5.1.4.x. I'm up to 5.2.0.4 and it's still there, at least with this file.

paul1149 gravatar imagepaul1149 ( 2016-08-02 20:39:02 +0100 )edit
0

answered 2016-08-02 18:53:19 +0100

petermau gravatar image

If you are processing large documents, you may well find that the Memory settings need to be adjusted. TOOLS > OPTIONS > MEMORY. The Getting Started Guide - Chapter 2: Setting up LibreOffice, which you can download directly gives help in this area. The default settings are suitable for smaller documents. I always adjust this option when installing systems for other users.....

edit flag offensive delete link more

Comments

Thanks, Peter. I already had done this, to the tune of 600+MB for the prog, and 8MG for each object.

I'm beginning to think that this file's abnormally high number of footnotes may have bollixed something. I'm talking several thousand.

BW.

paul1149 gravatar imagepaul1149 ( 2016-08-02 18:58:53 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-01 21:44:55 +0100

Seen: 634 times

Last updated: Aug 02 '16