Ask Your Question
0

Problem with install Libreoffice 5.2 Linux

asked 2016-08-04 18:05:01 +0200

marko_simic gravatar image

Hello I tired to install Libreoffice5.2 at Opensuse11.1. On this machine I do not have internet access, I did rpm -Uvh .rpm and everything were OK. But wen I start libreoffice I getting error message *server:~/LibreOffice_5.2.0.4_Linux_x86-64_rpm/RPMS # libreoffice5.2 /opt/libreoffice5.2/program/javaldx: error while loading shared libraries: /opt/libreoffice5.2/program/libjvmfwklo.so: ELF file OS ABI invalid Warning: failed to read path from javaldx /opt/libreoffice5.2/program/soffice.bin: error while loading shared libraries: /opt/libreoffice5.2/program/libmergedlo.so: ELF file OS ABI invalid server:~/LibreOffice_5.2.0.4_Linux_x86-64_rpm/RPMS #

I deleted .conf/libreoffice directory, but I am getting the same error Everything is OK in version 5.0.2 but in any new version I have this issue. I have compared system requirements at my machine and everything is looks OK Can someone help me ? Cheers Marko

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-10-12 10:12:22 +0200

ederag gravatar image

This reason might be given in this answer:

The loader on your system does not support the new Linux ABI. Until relatively recently, Linux ELF binaries used the System V ABI. Recently, in support of STT_GNU_IFUNC, the Linux ABI was added.

On OpenSUSE-10.3, installing LibreOffice-5.1.5.2_Linux_x86_rpm, almost the same error occured:

/opt/libreoffice5.1/program/oosplash: error while loading shared libraries: /opt/libreoffice5.1/program/libuno_sal.so.3: ELF file OS ABI invalid

and indeed

> file /opt/libreoffice5.1/program/libuno_sal.so.3
/opt/libreoffice5.1/program/libuno_sal.so.3: ELF 32-bit LSB shared object, Intel 80386, version 1 (GNU/Linux), not stripped

while

> file /lib/ld-*.so
/lib/ld-2.6.1.so: ELF 32-bit LSB shared object, intel 80386, version 1 (SYSV), stripped

the former has GNU/Linux while the latter has SYSV

Guess it's time to upgrade...

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-04 18:05:01 +0200

Seen: 662 times

Last updated: Oct 12 '16