Ask Your Question
0

Can not set text language for spell check in libre office version 5.1.4.2

asked 2016-08-07 10:17:55 +0200

FritsMenno gravatar image

updated 2016-08-07 20:45:07 +0200

floris v gravatar image

When pressing F7 one can set te text language for spell check. It says [none]. In the dropdown box i can choose from a whole slew of languages, but none of them will stick. I already removed the profile but that does not solve the problem.

Regards, Frits van den Bergh

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2019-01-05 13:45:22 +0200

I had similar problems for checking my spelling in German. I had to download additional packages to fix it. I used this route:

Tools > Options > Language settings > Writing aids

Click on the edit button next to "availible language modules"

Click on the link for "get more dictionaries online"

Search for the dictionary you require, download and open the file. Restart and open libreoffice.

Should now recognise the language and spelling errors automatically - although I already changed my operating system locale and preffered languages to german so you may have to select your preferred writing language in libreoffice as an extra step.

edit flag offensive delete link more
0

answered 2016-08-07 10:49:16 +0200

floris v gravatar image

You don't set a language for text in the spell check dialog box. You can set the language for the main text in the paragraph style, for instance Default, and for individual words in a character style or by direct formatting. The Language list box is on the Font tab of the Paragraph style dialog box and of the Character style dialog box.

On a side note, I haven't used the spell check command for a long time, I consider it as a fossil from the time when spell check as you type was not yet available or too slow to be of use.

edit flag offensive delete link more
0

answered 2016-08-07 15:51:54 +0200

paul1149 gravatar image

At tools / options / language, do you have a language selected, including for default language for documents?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-07 10:17:55 +0200

Seen: 1,482 times

Last updated: Jan 05